Modify

Opened 12 years ago

Closed 12 years ago

#394 closed Bug (No Bug)

Strange TreeView behaviour, 2 different problems.

Reported by: Wooltown Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

In the treeview, the first time the WM Notify event is fired off, the first time I click on an item, and test for the Item ID using $hItem = _GUICtrlTreeView_GetSelection($TreeView) it is 0x00000000, error ?

In the Func TreeView_Click() I have added ;--- Change this on two lines to show what happens on the 10 root items if you click in the checkbox or on the text. If you have the first alternative active, if you click in the checkbox, it will always be checked, but if you click on the text it will always be unchecked.
If I use the other "Change this" line, the behaviour is reversed.

Testing on Windows 2000 SP4

Attachments (1)

treetest.au3 (2.5 KB) - added by Wooltown 12 years ago.

Download all attachments as: .zip

Change History (2)

Changed 12 years ago by Wooltown

comment:1 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

There is a lot wrong with that code. You need support, not reporting a bug. Some things I see wrong off-hand:

  • You don't use any of the information given to you by the message which gives you useful information about the item being clicked.
  • You're comparing numeric values as strings. Why? Your code really doesn't make sense there.
  • You don't return a value when you handle the click yourself. So you handle the click, then you let AutoIt handle the click, too.

Your code is a long way from being correctly written. Post on the forum to get support and get your code written correctly. Closing this as no bug because it's too hard to tell if the problem is you or AutoIt.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.