Modify

Opened 12 years ago

Closed 12 years ago

#395 closed Bug (No Bug)

DriveGetDrive and @ScriptDir under windows Vista run as administrator

Reported by: bart.wical@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

If you mount a drive then run a compiled script as administrator. The code below illustrates the issue. Note if you run the copiled script without the rights elevation it works as expected

$var = DriveGetDrive( "NETWORK" )


If NOT @error Then
	MsgBox(4096,"", "Found " & $var[0] & " drives")
	For $i = 1 to $var[0]
		MsgBox(4096,"Drive " & $i, $var[$i])
	Next
Else
	MsgBox(0,"Error",@error)
EndIf

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

This is not unexpected (to me) nor is it a bug. This blog explains it better than I can. You can test with Windows Explorer (with elevated privileges) that the issue isn't isolated to AutoIt.

Closing as no bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.