Modify

Opened 11 years ago

Closed 11 years ago

#525 closed Bug (No Bug)

0x8007007E error when compiled 32 bit. OK when compiled 64 bit. Reopened.

Reported by: drummer Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

The Run function returns error 0x8007007E when I run the attached script after compiling for 32 bit. It works fine when compiled 64 bit or if run as a script (Testit2.AU3). My environment is Vista Ultimate 64 bit version. W32tm.exe which is being run exists in C:\Windows\System32. This bug was originally submitted as #469. I specified the full path as was suggested and the problem still occurs. This really does seem to be a bug.

Thanks,

  • Dave

Attachments (2)

Testit2.AU3 (427 bytes) - added by anonymous 11 years ago.
Testit2.2.AU3 (427 bytes) - added by drummer 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by anonymous

Changed 11 years ago by drummer

comment:1 Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

You have to turn WOW64 redirection off. Windows is going to continue to redirect the system32 directory for a 32-bit process to the SYSWOW64 directory which contains the 32-bit files. That's why you get the "module not found" error - it's not looking where you think it is.

Look at Using AutoIt -> Running under Windows 64-bit Edition in the documentation for more information about directory/registry redirection under 64-bit Windows and what you can do to turn it off.

This is still not a bug in AutoIt.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.