Modify

Opened 11 years ago

Closed 11 years ago

#602 closed Feature Request (Rejected)

AutoitWrapper Methods for Handling 'Run After'

Reported by: Asaman83687 Owned by:
Milestone: Component: Other
Version: Severity: None
Keywords: AutoitWrapper Cc:

Description

I compiled my script for an experiment when i encountered this error on console window of Scite


'ResHacker.exe' is not recognized as an internal or external command,
operable program or batch file.


with an autoitwrapper code of

#AutoIt3Wrapper_Run_After=ResHacker.exe -add %out%, %out%, image3.jpg, rcdata, TEST_JPG_3, 0

but it turned OK when I used

#AutoIt3Wrapper_Run_After=Start ResHacker.exe -add %out%, %out%, image3.jpg, rcdata, TEST_JPG_3, 0

I think AutoitWrapper must somehow change it's way of handling running after/before events because it uses

Run(@ComSpec & ' /C ' & $INP_Run_After[$x] & '', '', @SW_HIDE, $STDERR_CHILD + $STDOUT_CHILD)

in running other programs which can produce errors

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by TicketCleanup

  • Version 3.2.13.8 deleted

Automatic ticket cleanup.

comment:2 Changed 11 years ago by Jos

  • Resolution set to Rejected
  • Status changed from new to closed

Use the fully qualified pathfor the exe to make sure it knows where to look for it.
Also please post these type of "issues" in the support forum so we can establish what the issue is and don;t think it belongs is the "New features request" section.

Jos

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.