Modify

Opened 11 years ago

Closed 11 years ago

#638 closed Bug (No Bug)

StdoutRead function returns null character mid string in default text mode

Reported by: fill_hard@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.1 Severity: None
Keywords: Cc:

Description

I updated to the latest Public (3.2.12.1) and found my script no longer worked. On debuging found that StdoutRead seem to miss the last line of data, this is not the case, it is returning all of the data, but with a null character between the two data segments, even when using the default text option.

I'm sure this is how Cipher.exe is outputing the data.
However it has the effect of stopping you seeing the data in the output text string using a msgbox, writing the text to a file using FileWriteLine. It can still be checked for with in the text sting using a StringInStr. If you string the data any text after the null character is lost.

Previous versions gave the complete text output without the null character. Is this a bug or by design ?

$Cipher = Run (@SystemDir & "\cipher " & """" & @MyDocumentsDir & """", @SystemDir, @SW_HIDE, $STDERR_CHILD + $STDOUT_CHILD)

Using binary mode you get an output of:

0x0D0A204C697374696E6720433A5C446F63756D656E747320616E642053657474696E67735C753737353136305C0D0A204E65772066696C657320616464656420746F2074686973206469726563746F72792077696C6C206E6F7420626520656E637279707465642E0D0A0D0A000x45204D7920446F63756D656E74730D0A00

Attachments (0)

Change History (1)

comment:1 Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Stop creating tickets for support requests. Just because the behavior has changed and doesn't work like it used to doesn't mean AutoIt is bugged. Stop wasting my time creating these stupid tickets already.

Since the program is outputting non-string data, read it as binary data and convert it to a string. Not very hard to figure that out on your own if you'd take some time to think about the problem instead of rushing to create a ticket every day.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.