Modify

Opened 11 years ago

Closed 11 years ago

#662 closed Bug (No Bug)

ListView setting $LVS_EX_FLATSB flattens header only instead of scrollbars

Reported by: sys55@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.1 Severity: None
Keywords: $LVS_EX_FLATSB, ListView, Scrollbar Cc:

Description

Bug in AutoIt Version: 3.2.12.1

ListView setting $LVS_EX_FLATSB flattens header only instead of scrollbars

ListView Control with $LVS_EX_FLATSB set does not flatten the scrollbars. The header though gets flattened, something not wished.
See attached file for a demo.

Running XP professional SP3, classic Windows theme.



#include <ButtonConstants.au3>
#include <GUIConstantsEx.au3>
#include <ListViewConstants.au3>
#include <WindowsConstants.au3>
#Include <GuiListView.au3>

#Region ### START Koda GUI section ### Form=
$Form1 = GUICreate("Form1", 409, 301, 302, 218)
$ListView1 = GUICtrlCreateListView("qwer|asdf|sdfg|zxcv|qwer|sdfg", 32, 24, 337, 169)
GUICtrlSendMsg(-1, $LVM_SETCOLUMNWIDTH, 0, 50)
GUICtrlSendMsg(-1, $LVM_SETCOLUMNWIDTH, 1, 50)
GUICtrlSendMsg(-1, $LVM_SETCOLUMNWIDTH, 2, 50)
GUICtrlSendMsg(-1, $LVM_SETCOLUMNWIDTH, 3, 50)
GUICtrlSendMsg(-1, $LVM_SETCOLUMNWIDTH, 4, 50)
GUICtrlSendMsg(-1, $LVM_SETCOLUMNWIDTH, 5, 50)
$ListView1_0 = GUICtrlCreateListViewItem("asdf", $ListView1)
$ListView1_1 = GUICtrlCreateListViewItem("sadf", $ListView1)
$ListView1_2 = GUICtrlCreateListViewItem("asdf", $ListView1)
$ListView1_3 = GUICtrlCreateListViewItem("asfdg", $ListView1)
$ListView1_4 = GUICtrlCreateListViewItem("sdfg", $ListView1)
$ListView1_5 = GUICtrlCreateListViewItem("asdf", $ListView1)
$ListView1_6 = GUICtrlCreateListViewItem("qwedf", $ListView1)
$ListView1_7 = GUICtrlCreateListViewItem("asfdg", $ListView1)
$ListView1_8 = GUICtrlCreateListViewItem("sdfg", $ListView1)
$ListView1_9 = GUICtrlCreateListViewItem("asdf", $ListView1)
$ListView1_10 = GUICtrlCreateListViewItem("fsdg", $ListView1)
$ListView1_11 = GUICtrlCreateListViewItem("dfg", $ListView1)
$ListView1_12 = GUICtrlCreateListViewItem("sdaf|df", $ListView1)
$ListView1_13 = GUICtrlCreateListViewItem("sfdg", $ListView1)
$ListView1_14 = GUICtrlCreateListViewItem("sdf", $ListView1)
$ListView1_15 = GUICtrlCreateListViewItem("ase", $ListView1)
$ListView1_16 = GUICtrlCreateListViewItem("", $ListView1)
$Button1 = GUICtrlCreateButton("Set $LVS_EX_FLATSB ", 32, 224, 161, 33, 0)
$Button2 = GUICtrlCreateButton("Clear $LVS_EX_FLATSB ", 216, 224, 169, 33, 0)
GUISetState(@SW_SHOW)
#EndRegion ### END Koda GUI section ###

$OriginalExStyle = _GUICtrlListView_GetExtendedListViewStyle($ListView1)

While 1
	$Msg = GUIGetMsg()
	Switch $Msg
		Case $GUI_EVENT_CLOSE
			ExitLoop
		Case $Button1
			_GUICtrlListView_SetExtendedListViewStyle($ListView1, BitOR($OriginalExStyle,$LVS_EX_FLATSB))
		Case $Button2
			_GUICtrlListView_SetExtendedListViewStyle($ListView1, $OriginalExStyle)
	EndSwitch
WEnd

Attachments (1)

Demo of bug in $LVS_EX_FLATSB - code & images.zip (9.4 KB) - added by anonymous 11 years ago.
Demo of bug in $LVS_EX_FLATSB - code & images

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by anonymous

Demo of bug in $LVS_EX_FLATSB - code & images

comment:1 Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

This is not a bug. Flat scrollbars are not supported when using comctl32.dll 6.00 which is what AutoIt uses on Windows XP.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.