Modify

Opened 11 years ago

Closed 11 years ago

#664 closed Bug (No Bug)

SciTE Magnifying (Zooming) doesn't properly update horizontal scrollbar

Reported by: sys55@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.1 Severity: None
Keywords: SciTE, scrollbar, zooming Cc:

Description

Using SciTE 1.77 full package from 2-11-2008 SciTE4AutoIt3.exe
(4554Kb) and AutoIt Version: 3.2.12.1

Bug: SciTE Magnifying (Zooming) doesn't properly update horizontal scrollbar
Description: When a line of code extends beyond the visible part of SciTE, the horizontal scrollbar when scrolled to the far right does not always show the complete line. The scorllbar adjusts itself to the lines visible, but even clicking the line does not update the scrollbar. You must click the right arrow to have the screen scroll further to the right.
This bug happens when a smaller lines of text are also visible. It seems the scrollbar only makes those lines visible.
The scrollbar behaves properly though in the SciTE light version 1.76.

Included: a piece of code showing the bug. Click the IniWrite-line and zoom in. The end of the line cannot be seen, although the end of the ...($ComboDir)) line does.
Image 1: showing the truncated line when the ...($ComboDir)) line is also visible.
Image 2: the full line does show up now when the shorter ...($ComboDir)) line has moved out of sight.

P.S.1: The Output message "Need to change au3.properties: BETA_AUTOIT =0" when running SciTE for the first time when no Beta is installed is disturbing: should the user do something? is this a SciTE beta? Help! Only after some research I found the LUA startup script issuing this info message. Please remove it or rephrase it to something like "No AutoIt beta version detected. Your au3.properties have been updated."

P.S.2: the forum doesn't show emoticons but links to emoticons (IMG:http://www.autoitscript.com/forum/style_emoticons/autoit/smile.gif). Please correct this at last, it makes reading cumbersome.

P.S.3: Please update the forum search engine. Many times it gives an error on almost every search. Only after several retries it comes up with the results. Searching within results is most needed too. Also: point to the pages where to find the item instead of pointing to the full article (with many pages). Please also allow viewing sorted results on date first. Presently it's a nightmare to find things on the forum, defying its usefullness.

Attachments (1)

Demo of bug in Scite 1.77 full version.zip (27.7 KB) - added by anonymous 11 years ago.
code and 2 images

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by anonymous

code and 2 images

comment:1 Changed 11 years ago by Valik

It's pretty much useless to post more than one issue per ticket. Don't do it. However, 2 of your issues don't belong on the issue tracker anyway (the last two).

As for the scrollbar issue, I don't see it. Everything works fine for me using a custom built version of SciTE from the same source as SciTE4AutoIt. It could be the Lua script as my scripts are a little different.

Lastly, have you tried doing what the error message you find so scary says? I imagine if you open au3.properties you will find a line like:

BETA_AUTOIT=1

And that message is telling you to change that to:

BETA_AUTOIT=0

comment:2 Changed 11 years ago by Jos

We use the standard distribution done by Neil Hodgson as the base of our SciTE4AutoIt3 and only maintain the additions, mainly LUA scripts. I have no intention to start to do more work on bug fixing for SciTE.

As to the "Need to change au3.properties: BETA_AUTOIT =0" message. This is correct and normally only show one time when it was successful. it will again give one message after AutoIt3 Beta was installed. This is not a bug but a feature.

Jos

comment:3 Changed 11 years ago by Jos

  • Resolution set to No Bug
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.