Jump to content

Search the Community

Showing results for tags 'CDO.DropDirectory'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements and Site News
    • Administration
  • AutoIt v3
    • AutoIt Help and Support
    • AutoIt Technical Discussion
    • AutoIt Example Scripts
  • Scripting and Development
    • Developer General Discussion
    • Language Specific Discussion
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Categories

  • AutoIt Team
    • Beta
    • MVP
  • AutoIt
    • Automation
    • Databases and web connections
    • Data compression
    • Encryption and hash
    • Games
    • GUI Additions
    • Hardware
    • Information gathering
    • Internet protocol suite
    • Maths
    • Media
    • PDF
    • Security
    • Social Media and other Website API
    • Windows
  • Scripting and Development
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


WWW


Interests

Found 1 result

  1. ...or maybe with the way it now communicates with CDO.DropDirectory. We have a script that monitors e-mails that come in to a drop directory. The script looks at the e-mails and sends a response accordingly to the user that sent the e-mail. However, after updating to the latest AutoIt, I cannot compile due to a supposed syntax error which does not exist. Here is the relevant code: $objDropDirectory = ObjCreate("CDO.DropDirectory") $colMessageCollection = $objDropDirectory.GetMessages($DropFolder) If $colMessageCollection.Count > 0 Then For $msg In $colMessageCollection $fileFullPath = $colMessageCollection.Filename($msg) If StringInStr($msg.To, "daily", 2) Then ...do stuff... EndIf Next EndIfThe error I receive upon compiling is this: (36,26) : ERROR: missing separator character after keyword. If StringInStr($msg.To, Clearly, there is a separator character. The comma is right there. This wasn't happening before 3.3.8.x. Any ideas?
×
×
  • Create New...