Jump to content

Search the Community

Showing results for tags '_ArraySearch'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements and Site News
    • Administration
  • AutoIt v3
    • AutoIt Help and Support
    • AutoIt Technical Discussion
    • AutoIt Example Scripts
  • Scripting and Development
    • Developer General Discussion
    • Language Specific Discussion
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Categories

  • AutoIt Team
    • Beta
    • MVP
  • AutoIt
    • Automation
    • Databases and web connections
    • Data compression
    • Encryption and hash
    • Games
    • GUI Additions
    • Hardware
    • Information gathering
    • Internet protocol suite
    • Maths
    • Media
    • PDF
    • Security
    • Social Media and other Website API
    • Windows
  • Scripting and Development
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


WWW


Interests

Found 4 results

  1. Hello everybody, so I might found a bug in _ArraySearch: #include <Array.au3> Local $abc[2] = ["b", "b"] $h = "+---------------------------------+" & @CRLF ConsoleWrite($h) For $i = 0 To 1 $abc[0] = 0 out() $abc[0] = 1 out() $abc[0] = -1 out() $abc[0] = "Abc" out() $abc[1] = "Hello" Next Func txt() Return "$abc = [" & $abc[0] & ", " & $abc[1] & "]" & @CRLF & _ "> _ArraySearch($abc,""Hello"") = " EndFunc ;==&
  2. Hi, i have a 2d array and i am using _ArraySearch to find the index of an array element. I store the result in a variable. When i show the variable, i see just a digit like "1", instead of "[1][3]" or something like that. Can someone tell me how to get the number of row and column of the searched element? Thanks in advance
  3. . THX I should use _arraysearch or there is another function to be used? #include <Array.au3> #include <File.au3> Global Const $sFilePath = @ScriptDir&"\1.txt",$sFilePath2= @ScriptDir&"\2.txt" FileOpen($sFilePath,$FO_OVERWRITE) For $x = 1 to 10 FileWriteLine($sFilePath,$x&"test") Next FileClose($sFilePath) FileOpen($sFilePath2,$FO_OVERWRITE) For $x2 = 1 to 5 FileWriteLine($sFilePath2,$x2&"test") Next FileClose($sFilePath2) Local $aRetArray,$aRetArray2 $aArray = _F
  4. Local $aArray_1[3] = [0,'x',2] $a1 = Execute('$aArray_' & 1 ) If @error Then Msgbox(0,@error,'Execute not working') _ArrayDisplay($a1) $i1 = _ArraySearch($a1,'y') If @error Then Msgbox(0,@error,'not working - 0') ConsoleWrite('$i1: ' & $i1 & @CRLF) $i1 = _ArraySearch($a1,'x') If @error Then Msgbox(0,@error,'not working - 1') ConsoleWrite('$i1: ' & $i1 & @CRLF) $i1 = _ArraySearch($aArray_1,'y') If @error Then Msgbox(0,@error,'not working - 2') ConsoleWrite('$i1: ' & $i1 & @CRLF) $i1 = _ArraySearch($aArray_1,'x') If @error Then Msgbox(0,@error,'not working - 3') Con
×
×
  • Create New...