Jump to content

Search the Community

Showing results for tags 'arrayfindall'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements and Site News
    • Administration
  • AutoIt v3
    • AutoIt Help and Support
    • AutoIt Technical Discussion
    • AutoIt Example Scripts
  • Scripting and Development
    • Developer General Discussion
    • Language Specific Discussion
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Categories

  • AutoIt Team
    • Beta
    • MVP
  • AutoIt
    • Automation
    • Databases and web connections
    • Data compression
    • Encryption and hash
    • Games
    • GUI Additions
    • Hardware
    • Information gathering
    • Internet protocol suite
    • Maths
    • Media
    • PDF
    • Security
    • Social Media and other Website API
    • Windows
  • Scripting and Development
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


WWW


Interests

Found 1 result

  1. Appreciate some help with this Initially I had a [6][3] array & ArrayFindAll works Then I made it a [6][4] & then a [6][9] arrays & ArrayFindAll doesn't works @error = 6 - $vValue was not found in array #include <array.au3> Global $aArray[6][3] = [[1, "A", "1111"], [2, "B", "2222"], [3, "C", "3333"], [4, "D", "4444"], [5, "E", "5555"], [6, "F", "6666"]] ;Global $aArray[6][4] = [[1, "A", "1111","G"], [2, "B", "2222", "M"], [3, "C", "3333", "S"], [4, "D", "4444", "Y"], [5, "E", "5555", "B1"], [6, "F", "6666", "C1"]] ;Global $aArray[6][9] = [[1, "A", "1111", "G", "H","I","J","K","L"], [2, "B", "2222", "M","N", "O","P","Q", "R"], [3, "C", "3333", "S", "T","U","V","W","X"], [4, "D", "4444", "Y", "Z","A1","A2","A3","A4"], [5, "E", "5555", "B1", "B2","B3","B4","B5","B6"], [6, "F", "6666", "C1", "C2","C3","C4","C5","C6"]] _ArrayDisplay($aArray) Local $aiResult = _ArrayFindAll($aArray, "5555",0,0,0,1,3) If @error = 0 Then _ArrayDisplay($aiResult) Else MsgBox(0,"","Error " & @error) EndIf Exit
×
×
  • Create New...