Jump to content

Search the Community

Showing results for tags 'license'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements and Site News
    • Administration
  • AutoIt v3
    • AutoIt Help and Support
    • AutoIt Technical Discussion
    • AutoIt Example Scripts
  • Scripting and Development
    • Developer General Discussion
    • Language Specific Discussion
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Categories

  • AutoIt Team
    • Beta
    • MVP
  • AutoIt
    • Automation
    • Databases and web connections
    • Data compression
    • Encryption and hash
    • Games
    • GUI Additions
    • Hardware
    • Information gathering
    • Internet protocol suite
    • Maths
    • Media
    • PDF
    • Security
    • Social Media and other Website API
    • Windows
  • Scripting and Development
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


WWW


Interests

Found 4 results

  1. Hi. I am writing a program that I want to use it to earn some money, so I have an idea that insert the license checking into it. But I haven't had a code yet. This is my idea: -Put my licenses onto my host with their limit days. -Every day the customers run the program with the license and the program will show costumers how many days left... Can you give me an example for that program? Thanks a lot if you can help me!
  2. Hi there, the title says it all. My problem here is: im starting the autoit compiled .exes from a cmd window. So im also passing needed parameters there. These parameters are in this case paths to files, and sometimes some slashes within these paths got switched with the german "ß" character which lies on the same key as the backslash. After checking the cmd window the .exe call with the parameter includes the correct path. For some odd reason its only happening sometimes and also only in the license_A_Prof_Sec function. So any hints what could cause this problem? Here is my code: #RequireAdmin run("C:\Program Files (x86)\Avira\AntiVir Desktop\avcenter.exe") sleep(2000) $aWins=WinList("Avira") For $i = 1 To $aWins[0][0] Switch $aWins[$i][0] case "Avira Professional Security" license_A_Prof_Sec($aWins[$i][1]) Case "Avira Free Antivirus" license_A_Free_AV($aWins[$i][1]) EndSwitch Next func license_A_Free_AV($handle) WinActivate($handle) sleep(3000) Send("!H") Send("m") $whnd=winwait("Avira Free Antivirus","Lizenz",60) ControlClick($whnd,"","[CLASS:Static; INSTANCE:4]") $whnd=winwait("Öffnen") ControlSend($whnd,"","[CLASS:Edit; INSTANCE:1]",$CMDLine[1]) ControlClick($whnd,"","[CLASS:Button; INSTANCE:1]") $whnd=WinWait("Avira Free Antivirus","Lizenz ist bereits vorhanden",60) ControlClick($whnd,"","[CLASS:Button; INSTANCE:1]") $whnd=WinWait("Avira Free Antivirus","Die Lizenzdatei wurde aktualisiert",60) ControlClick($whnd,"","[CLASS:Button; INSTANCE:1]") $whnd=WinWait("Avira Free Antivirus","Lizenzinformationen",60) sleep(500) ControlClick($whnd,"","[CLASS:Button; INSTANCE:8]") winclose("Avira Free Antivirus") EndFunc func license_A_Prof_Sec($handle) WinActivate($handle) sleep(3000) Send("!H") Send("l") $whnd=winwait("Öffnen","",60) ControlSend($whnd,"","[CLASS:Edit; INSTANCE:1]",$CMDLine[1]) ControlClick($whnd,"","[CLASS:Button; INSTANCE:1]") $whnd=WinWait("Avira Professional Security","Die Lizenzdatei wurde aktualisiert",60) ControlClick($whnd,"","[CLASS:Button; INSTANCE:1]") winclose("Avira Professional Security") EndFunc
  3. Hi all, i am struggeling with a problem creating a input box wich will automatic seperate the input letters with a - after 5 characters. example: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX i all ready have it limited to 29 characters and max of 29 characters. I hope any one can help me with this. The purpose for the script is, an automatic network installation of Windows 8. forum post.au3
  4. Hello, I have a quick question if people post code without a license, what is assumed on this forum? Its always good pratice to include the author in the comments but I don't see anything specific that gives any indication as to if I have the right to copy and include in my code. For one, I don't want legal trouble and second I couldn't find an answer anywhere for this question. It will be helpful to clarify what license is assumed when posting source code on this forum.
×
×
  • Create New...