Jump to content

Search the Community

Showing results for tags 'please help'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements and Site News
    • Administration
  • AutoIt v3
    • AutoIt Help and Support
    • AutoIt Technical Discussion
    • AutoIt Example Scripts
  • Scripting and Development
    • Developer General Discussion
    • Language Specific Discussion
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Categories

  • AutoIt Team
    • Beta
    • MVP
  • AutoIt
    • Automation
    • Databases and web connections
    • Data compression
    • Encryption and hash
    • Games
    • GUI Additions
    • Hardware
    • Information gathering
    • Internet protocol suite
    • Maths
    • Media
    • PDF
    • Security
    • Social Media and other Website API
    • Windows
  • Scripting and Development
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


WWW


Interests

Found 2 results

  1. Hey! Im just going to say that im new to autoit and this is my first successful script ! anyway i have a little problem that does not make sense at all to me.... Maybe you can help me out? Anyone please?? What i have the SCRIPT do is this : The script finds a text box (on the screen) then it clicks the text box, then it sends "guess what...." but after it has sent "guess what...." FOR SOME REASON IT SCROLLS DOWN THEN ENDS THE SCRIPT WITH AN ERROR.... (see below for error...) "C:\Users\yolo\Desktop\bot\best.au3" (47) : ==> Illegal text at the end of statement (one statement per line).: mousewheel("down"), 3) mousewheel("down")^ ERRORHERE IS MY SCRIPT BELOW... That im having problems with. func ns3() $pixel = PixelSearch(416, 295, 882, 315, 0x707070) if IsArray($pixel) = true then MouseClick("left", $pixel[0], $pixel[1]) tn() EndIf EndFunc func tn() send ("guess{SPACE}what.....") sleep ($interval) sleep ($interval) findcombox() EndFuncSo what happens is it searches for the text box, then if it's true then mouse click then Func tn() runs Then func tn sends "guess what...." then sleeps THEN IS SCROLLS DOWN AND AN ERROR COMES UP?!!?!?!? what the heck ?! oh BTW i have a few "Scroll func's" (See Below) Func scroll() mousewheel("down", 2) EndFunc func scroll3t() mousewheel("down"), 3) EndFunc func scrollup() mousewheel("up"), 20) EndFunc scroll () - scrolls twice down scroll3t() - scrolls 3 times scrollup() - YOU GUESSED IT! scrolls up SO?! What the heck is happening?! im so confused why it's scrolling down twice for no reason.... it's not like i have the scroll() in the tn() ??
  2. Hi, I'm trying to click on a button on IE but I failed to do so using IEAction and IEFormSubmit. I'm trying to click on the 'Login' button on URL: https://briefing.met.ie/login.php. Please see the source code of page below <form id="login" action="./login-result.php" method="post"> <div class="section"> <h1>Authentication</h1> <div id="login_section"> <p> <input type="hidden" name="action" value="login"/> <label for="username">Username:</label> <input type="text" id="username" name="username" /> </p> <p> <label for="password">Password:</label> <input type="password" id="password" name="password" /> </p> </div> </div> <div class="section"> <input class="navButton" type="submit" value="Login" /> </div> </form> Is there any specific method to click on button of class navButton? Please help me.
×
×
  • Create New...