Jump to content
Sign in to follow this  
Rambo

Firefox and IE: different matches with PixelGetcolor

Recommended Posts

Rambo

Hey there,

I´m working in an autoclicker. I coded a little app to recognize a certain pixel in a URL (using PixelGetColor) to know its status.

I coded it using Firefox becasue is my default browser. Everything goes fine, the app works, but i made a test with IE, and my surprise was the pixel colour did not match!

Its funny! i opened the same URLs with each browser and FF appears to be darker. Has anybody experienced this problem too?

Share this post


Link to post
Share on other sites
Genos

I've noticed a lot of differences between the two, mostly from how they handle html. I wouldn't be surprised to find slight difference in color as well >_

Share this post


Link to post
Share on other sites
somdcomputerguy

Maybe use Function PixelSearch, which allows one to define a 'shade-variation'


- Bruce /*somdcomputerguy */  If you change the way you look at things, the things you look at change.

Share this post


Link to post
Share on other sites
Rambo

Could be. Pixel color code in FF returns 1644309, and for IE 7032384. I dont know if this is a big variation, appears to be, because the numerical difference.

Or maybe i should find another way to recognize the status. Its a flash object

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×