Sign in to follow this  
Followers 0
TuMbLeWeEd

Chat Client/Server in one script (still buggy)

13 posts in this topic

#1 ·  Posted (edited)

UPDATE VERSION 0.0.1.4, SOURCE INCLUDED

Im creating a chat client/server with the au3xtra.dll &md5.dll, works fine at home

(still buggy and not every option is avialable, still work in progress :"> )

My intension is to create a chat with code sharing capabilities.

Meaning: you have a project and have a few people helping you.

chat about problems, transfer latest versions, auto notify open code files when you are editing them.

Now first tings first and get the chat fully done!

It's about 2200 lines of code know and only the basics work now (@home that is)

I can connect by my no-ip address via my second pc on my home lan.

I have a testserver version running @home (reachable via a no-ip.com redirect)

What is it doing now

-----------------------

-can create a client account (first time start, error checking is NOT totaly complete)

-loginscreen (if you did not save the password, always shows up on startup)

-chat works, and yes you can also chat with the server (the only user always in your contact list) so client/client chat works and client/server chat works

-minimize to tray and restore on icon click

-rightclick tray icon exit (DONE IN 0.0.1.3 - status change not implemented)

-on exit notify server and other users your offline

-userlist pro account on server (DONE IN 0.0.1.3 - adding users is manual for now)

ToDo for basic chat client/server:

--------------------------------------

-the help file behind the help button in the setup wizard (so dont use it for now)

DONE IN 0.0.1.3 - server setup save (only reason it's not working for now, mine runs on a manual config file)

DONE IN 0.0.1.3 - status changes (find a nice way to show user status in the GUI, now it's a list)

DONE IN 0.0.1.3 - send added userlist to the client

DONE IN 0.0.1.3 - send public users list to the client (if you set your account to "Public user", you wil end up in that list so all users have the abbility to add you)

DONE IN 0.0.1.3 - send notefication if some one added you to a list in the GUI

DONE IN 0.0.1.3 - send response if you accept or decline the user add

DONE IN 0.0.1.3 - send a block or unblock user to server (for blocking those annoying suckers :D )

DONE IN 0.0.1.3 - appear offline status

Dont want to upload the code for now (to much crap left in it, it's like my english :"> ) so you have to do it with the exe for now.

Dont worry that i will fuck up your pc or get some private data from your pc!

Have no intrest in that!

The only things send are the IP,computername and login name for identifying use so i can block users ho wil try to crack someone's passwords with a script

the password is send as an md5, so i dont even now them and nowone can get it from my pc without md5 cracking skils (md5 can be reversed i heard)

Need the 3.1.1.3++ version for that :)

Let me know if you test it!

it uses some text to speach if you want it :D

DONE IN 0.0.1.3 -

chance is there that hou have to create the dir:

C:\Documents and Settings\$USERNAME\Application Data\ChatBitch

saves the setup.ini to there

VERSION 0.0.1.4

Bug fixed: server status when online

CHATBITCH SERVER ONLINE: for you to test

ChatBitch_source_and_exe_0.0.1.4.zip

Edited by TuMbLeWeEd

Share this post


Link to post
Share on other sites



You have the same problem with yours as mine, bad router support. Besides that good job


[font="Times"] If anyone remembers me, I am back. Maybe to stay, maybe not.----------------------------------------------------------------------------------------------------------[/font][font="Times"]Things I am proud of: Pong! in AutoIt | SearchbarMy website: F.R.I.E.S.A little website that is trying to get started: http://thepiratelounge.net/ (not mine)[/font][font="Times"] ----------------------------------------------------------------------------------------------------------[/font][font="Arial"]The newbies need to stop stealing avatars!!! It is confusing!![/font]

Share this post


Link to post
Share on other sites

You have the same problem with yours as mine, bad router support. Besides that good job

<{POST_SNAPBACK}>

Should work as client, router makes no differece to that i think (or am i wrong)

Note the server is somtimes down as i'm working on the code!

What problems did you encounter with yours?

Can use some advice on that, have no router @home, so i can not test that!

Share this post


Link to post
Share on other sites

For the server, i know that au3xtra handles routers fine when its a client but when its a server i can't get it to work


[font="Times"] If anyone remembers me, I am back. Maybe to stay, maybe not.----------------------------------------------------------------------------------------------------------[/font][font="Times"]Things I am proud of: Pong! in AutoIt | SearchbarMy website: F.R.I.E.S.A little website that is trying to get started: http://thepiratelounge.net/ (not mine)[/font][font="Times"] ----------------------------------------------------------------------------------------------------------[/font][font="Arial"]The newbies need to stop stealing avatars!!! It is confusing!![/font]

Share this post


Link to post
Share on other sites

Are the ports forwarded by the router?

Share this post


Link to post
Share on other sites

Are the ports forwarded by the router?

<{POST_SNAPBACK}>

My program works just fine between a firewalled router, but you have to forward the ports you are using, like SlimShady says..

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

My program works just fine between a firewalled router, but you have to forward the ports you are using, like SlimShady says..

<{POST_SNAPBACK}>

My idea also (have being wrong before, so dont kill me for that :) )

Specified that in the setup, when you select "Run as server" with a msgbox (sets default to lan IP then), it wil test the connection when you pressed the "check" button. If that fails, dont even try to run a server. (as the setup.ini file is not saved, it wil not work, standard is configured to my no-ip redirect)

Will try a port forwarding from my second pc (connect tru ICS, have no router available)

So it's tested in my case.

And wil fix the ini file saving.

Note that you dont bind to your real ip, bind to your local ip with your server.

Works for ICS for me!

Edited by TuMbLeWeEd

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

When i try to run my server for ez chat i bind it to my local ip address and my router is supposed to forward it but it wont

edit: oh yeah sevral other people in the development tried to but they couldn't do it either

Edited by Xenogis

[font="Times"] If anyone remembers me, I am back. Maybe to stay, maybe not.----------------------------------------------------------------------------------------------------------[/font][font="Times"]Things I am proud of: Pong! in AutoIt | SearchbarMy website: F.R.I.E.S.A little website that is trying to get started: http://thepiratelounge.net/ (not mine)[/font][font="Times"] ----------------------------------------------------------------------------------------------------------[/font][font="Arial"]The newbies need to stop stealing avatars!!! It is confusing!![/font]

Share this post


Link to post
Share on other sites

When i try to run my server for ez chat i bind it to my local ip address and my router is supposed to forward it but it wont

edit: oh yeah sevral other people in the development tried to but they couldn't do it either

<{POST_SNAPBACK}>

Dont know why that could be, maybe port nr is to high!

Would not know why you have to build some special router support in to a program, could not think of a way to do that.

Possible awnser is (noticed that with my webpage) if someone try'd to connect to my site and was connected tru the isp's proxy of the same provoder as i, it did not work! All the ip addresses from my provider are blocked he connected with the proxy they provide.

My isp lets us also connect to the net without a proxy (then no problem), so if yours is not: you have bad luck and it will never work sinds there is no proxy support in the dll. DO NOT BLAME YOUR PROG, PROVIDERS MESS UP THINGS

Also all outgoing traffic under 1024 is always blocked by my provider.

Sinds you are running your own web page, that should not be the problem (you would have noticed that)

Share this post


Link to post
Share on other sites

Currently i'm trying to run it on port 91. It really bugs me.


[font="Times"] If anyone remembers me, I am back. Maybe to stay, maybe not.----------------------------------------------------------------------------------------------------------[/font][font="Times"]Things I am proud of: Pong! in AutoIt | SearchbarMy website: F.R.I.E.S.A little website that is trying to get started: http://thepiratelounge.net/ (not mine)[/font][font="Times"] ----------------------------------------------------------------------------------------------------------[/font][font="Arial"]The newbies need to stop stealing avatars!!! It is confusing!![/font]

Share this post


Link to post
Share on other sites

#11 ·  Posted (edited)

Made a new version, now source included! :D

Give me some feedback if you like it :)

Can have multiple accounts:

creates an entry in the startmenu chatbitch=>setup on start

run this to make new accounts

Accounts made will also add an entry with Server/client & accountname

Some known bugs i can remember:

After setup off server, it will need a prog restart (kill it first)

Change online status server when no one online fails

When client is minimized and server goes down, restore and exit fails (kill the fucker then)

just found a new one, when delimiter char used in send text (and i do catch that with a stringreplace before it is send)=wrong error it says

ERROR:

Connection with server lost,

message not delivered!

nothing wrong with connection, damn :huh:

Have fun looking at the code, i workt on it for some time (and it's still a mess :D )

Edited by TuMbLeWeEd

Share this post


Link to post
Share on other sites

I only tried the exe right now...been about 3 minutes trying to get it to work. Set computer as server, relaunched the program, and it says server offline...How to fix?

Also, can a comp be a server and client at the same time?

...Time for Sleep


Writing AutoIt scripts since
_DateAdd("d", -2, _NowCalcDate())

Share this post


Link to post
Share on other sites

#13 ·  Posted (edited)

I only tried the exe right now...been about 3 minutes trying to get it to work.  Set computer as server, relaunched the program, and it says server offline...How to fix?

Also, can a comp be a server and client at the same time?

...Time for Sleep

<{POST_SNAPBACK}>

1)It's a bug that the status keeps offline, so it's actual online and listning for incomming connections if the background color is green of the server label (my fault, will fix the status EDIT: = fixed now)

Yes you can have a multiple clients on the same pc connecting to your server or another server or even run other servers on different ports (dont see the use for that, but it's possibe)

just look for the setup schortcut in your startmenu, or run the prog with the "config" commandline option

At save there will be a shortcut created for that account so you can easely start it.

note: when server you can not add, block or remove clients. (have to disable that or hide it or some other option) all users have the abbility to chat with you!

Will think off some options to do with the current GUI maybe.

Edited by TuMbLeWeEd

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0