Sign in to follow this  
Followers 0
laffo16

Stop Scite Removing Tab Indentations

4 posts in this topic

exactly as the title describes, when i save an au3 in scite 1.78 my tab indentations (which have no code on the same line) are removed. I like to keep these indents for structuring reasons. i'm positive this is a new thing which has been added and i just prefer the old way without scite removing my blank tab indents on save. how do i fix this?

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

That is a Jos question for he usually handles the SciTE stuff. I'm looking at the settings on mine to see what you can tweak to fix this. Give me a bit. It may be tomorrow before I can give you an answer.

Edit: can I get a screenshot of before and after so I can see just what it is doing?

Edited by Volly

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

This default was added a while ago:

strip.trailing.spaces=1

If you do not want trailing whitespace (spaces or Tabs) removed than you can override this behaviour by specifying this in the SciTEUser.Properties:

strip.trailing.spaces=0

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

thanks for your help guys, strip.trailing.spaces=0 has done the trick. found it in "Options / Open Global Options File".

Posted Image

it is only a very small problem, but i have just grown familuar with this default over the years.

Edited by laffo16

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0