Sign in to follow this  
Followers 0
demandnothing

need help with pixelbot color lock

2 posts in this topic

ok, i've been trying to use autoit for about a week now.. the problem i am having is with this code

While 1
    Sleep(30)
    If $ON = True Then
        $coord = PixelSearch(450, 250, 700, 550, $color, 3, 2)
        If IsArray($coord) = 1 Then
            MouseClick("left", $coord[0], $coord[1], 10, 0)
                EndIf
    EndIf
WEnd

my problem isnt with the pixelsearch.. its with the mouseclick code.. see the program i want to use this for uses your mouse to look around with.. so your mouse pointer is always at the center of the screen.. full screen first person shooter game.

thing is that when im not in game it works fine.. goes directly to the pixel and clicks it. but when im in game the color appears and my mouse goes haywire spinning and looking up.. how would i fix this?

Share this post


Link to post
Share on other sites



seriously. why does the edit button go away??

i was gonna add that i've tried everything i can think of.. combining mousemove and mouseclick commands like everybody says to do it, doesnt seem to work or i cant get the right settings for it.

MouseMove($coord[0],$coord[1])
MouseClick($coord[0],$coord[1])

with all different kinds of speeds, making one instant and the other at 100, even making them both at 50.. but still when in game it always looks up and spins around like crazy.

i think its because it doesnt realize that the pixels are mobile.. it sees a pixel at one point and goes to that point instead of following the pixel.. any ideas on how to fix this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0