Sign in to follow this  
Followers 0
voodoo

HELP, wanna build a bot.

11 posts in this topic

Hello, I want to build a bot.

I try pixelgetcolor but the game keeps giving me 0-00000 dont know why.

THe game has Xtrap.

I read in forum that I need to use pixelgetcolor function then pixelsearch and mousepoint/click. What should I do?

Share this post


Link to post
Share on other sites



Hello, I want to build a bot.

I try pixelgetcolor but the game keeps giving me 0-00000 dont know why.

THe game has Xtrap.

I read in forum that I need to use pixelgetcolor function then pixelsearch and mousepoint/click. What should I do?

Pixelgetcolor returns the color of a pixel at specified coordinates. Make sure your coordinates aren't on a white square (hence the 0-00000).

The easiest way is to use the autoit window info tool (included with the autoit download). Hover your mouse over a color, and it can tell you the color code for that color.

Share this post


Link to post
Share on other sites

Pixelgetcolor returns the color of a pixel at specified coordinates. Make sure your coordinates aren't on a white square (hence the 0-00000).

The easiest way is to use the autoit window info tool (included with the autoit download). Hover your mouse over a color, and it can tell you the color code for that color.

I did that but somehow, Xtrap blocks the autoitinfo...

Share this post


Link to post
Share on other sites

if your game is in full screen mode, try making a script that checks a color at a specific position after you activated the game. Maybe somehow the windowtool reads your desktop or something like it?

Share this post


Link to post
Share on other sites

if your game is in full screen mode, try making a script that checks a color at a specific position after you activated the game. Maybe somehow the windowtool reads your desktop or something like it?

Its not full window :/

Just cant do this... there is any program that can read the pixel color? Becouse I tried many scripts and auto info, got nothing.

Share this post


Link to post
Share on other sites

Oh ok I got you now.

You can hit print screen and paste the image into paint, then use the image to get the pixel color you're looking for. Only problem then is that if your game is still blocking the colors (if that's possible..) you still wouldn't be able to get checksums directly from the game.

As a workaround you could have it use print screen and paste it into paint, do your checksum, close paint, then have it click where you want. That would definitely be a pain though.

Share this post


Link to post
Share on other sites

Oh ok I got you now.

You can hit print screen and paste the image into paint, then use the image to get the pixel color you're looking for. Only problem then is that if your game is still blocking the colors (if that's possible..) you still wouldn't be able to get checksums directly from the game.

As a workaround you could have it use print screen and paste it into paint, do your checksum, close paint, then have it click where you want. That would definitely be a pain though.

LOL, already did that, but when I do a pixelsearch nothing happends, I think the problem is this game antihack called XTRAP! sight, dont know what to do, maybe bypass it? Dont know anything about AssemblY :???

Share this post


Link to post
Share on other sites

LOL, already did that, but when I do a pixelsearch nothing happends, I think the problem is this game antihack called XTRAP! sight, dont know what to do, maybe bypass it? Dont know anything about AssemblY :???

Taking an S/S should have nothing to do with the XTRAP. You sure you are doing it correctly lol.

Share this post


Link to post
Share on other sites

May I suggest you have a search of the forum. There are many threads on pixelsearch and botting here.


Post your code because code says more then your words can. SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y. Use Opt("MustDeclareVars", 1)[topic="84960"]Brett F's Learning To Script with AutoIt V3[/topic][topic="21048"]Valuater's AutoIt 1-2-3, Class... is now in Session[/topic]Contribution: [topic="87994"]Get SVN Rev Number[/topic], [topic="93527"]Control Handle under mouse[/topic], [topic="91966"]A Presentation using AutoIt[/topic], [topic="112756"]Log ConsoleWrite output in Scite[/topic]

Share this post


Link to post
Share on other sites

Taking an S/S should have nothing to do with the XTRAP. You sure you are doing it correctly lol.

U didnt understand, I took Shot and got the color BUT, when I try to pixelsearch in game, can't couse Xtrap blocks it.

Share this post


Link to post
Share on other sites

May I suggest you have a search of the forum. There are many threads on pixelsearch and botting here.

already did, spent 2 weeks searching and testing stuff... Also found one post that said I cant use autoit with Xtrap, dont know if that is true but I m kindoff beleiveing damn, if u guys wanna try game is RedWar, I m not a lazy bastard I really tried using stuff and building the bot.

If someone can try it please, I will apreciate.

Thank you again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0