Jump to content
Sign in to follow this  
burrito

Windows 7 Ventrilo and AutoIt

Recommended Posts

burrito

Hello, I'm new to the forums, i'm having trouble with this, when i hit my vent button it sometimes can take 1 second and it can sometimes take 2 seconds for it to actually start working(turn the button on), after i let go of the button it can take up to 3 seconds for it to stop (turn the button off).

I dont know if i have explained it well enough but im getting irritated with it because i love autoit. Please help if you can, Thanks!

Also wanted to let you know, as soon as i turn autoit off, vent works great, im assuming autoit is trying to pick up the key im using before it gets to vent.

Share this post


Link to post
Share on other sites
PsaltyDS

Hello, I'm new to the forums, i'm having trouble with this, when i hit my vent button it sometimes can take 1 second and it can sometimes take 2 seconds for it to actually start working(turn the button on), after i let go of the button it can take up to 3 seconds for it to stop (turn the button off).

I dont know if i have explained it well enough but im getting irritated with it because i love autoit. Please help if you can, Thanks!

Also wanted to let you know, as soon as i turn autoit off, vent works great, im assuming autoit is trying to pick up the key im using before it gets to vent.

Uhmm... is there any actual AutoIt code associated with this problem?

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites
burrito

Uhmm... is there any actual AutoIt code associated with this problem?

As far as an error, there isnt one, and as far as code i dont know where to look =\

Share this post


Link to post
Share on other sites
PsaltyDS

Uhmm... is there any actual AutoIt code associated with this problem?

As far as an error, there isnt one, and as far as code i dont know where to look =\

This is an AutoIt support forum. Does this question involve AutoIt in any way?

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites
burrito

Yes it does involve autoit, when i use it, it lags out my ventrilo i was wondering if autoit is trying to pick up my bind key for ventrilo. If so i was wondering if theres a way to stop picking that key up.

Share this post


Link to post
Share on other sites
PsaltyDS

Yes it does involve autoit, when i use it, it lags out my ventrilo i was wondering if autoit is trying to pick up my bind key for ventrilo. If so i was wondering if theres a way to stop picking that key up.

Open Task Manager and go to the Processes Tab. Click on the CPU column header to sort the processes based on CPU usage. Is your AutoIt script at the top of the list, sucking up all the cycles?

If it's not about CPU utilization, then what does this script have to do with Ventrilo? Is the script intended to monitor or automate Ventrilo or do anything else to it?

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites
burrito

Open Task Manager and go to the Processes Tab. Click on the CPU column header to sort the processes based on CPU usage. Is your AutoIt script at the top of the list, sucking up all the cycles?

If it's not about CPU utilization, then what does this script have to do with Ventrilo? Is the script intended to monitor or automate Ventrilo or do anything else to it?

:)

Yeah that sounds like it could be the problem, ill have to check when i get home, right now with my Autoit Script im only using it for keybinds, it has nothing to do with ventrilo, it just sounds like its lagging my system..... But thank you for your patience and help with this subject i know i didnt make my problem clear to begin with.

Share this post


Link to post
Share on other sites
Richard Robertson

You most likely have a loop without a call to Sleep. Add one.

Edited by Richard Robertson

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×