Sign in to follow this  
Followers 0
Tripredacus

[Solved/NotSolved] Insufficient Disk Space

4 posts in this topic

#1 ·  Posted (edited)

Long time no see!

I am having a problem, but not entirely sure if you guys will be able to help or not. I am using AutoIT to script a program install. I have been doing this for years but now starting to work with Windows 7. Here are my specs to start out:

Working Environment: Windows 7 Professional x86 in Audit Mode

IDE version: SciTE4AutoIt3 v1.76

AutoIT version: AutoIT v3.2.4.9 + Beta v3.2.3.6

App Converter: Aut2Exe v3 using ANSI

Application: Intel SECINST.EXE

Error: Insufficient Disk Space

Ok back to normal typing! My script (compiled to EXE) runs a bunch of programs that are located on the C Drive. One of which is the Intel SECINST.EXE. Don't bother looking this one up online, you won't find it. You can only get it if you are an Intel Channel Parter Premier Member. However, knowledge of this specific program may not be required, as (I hope) that similar problems have occured running other programs via AutoIT.

My script does not actually install the program, but merely launches it. This is because SECINST.EXE has no silent or unattend switch options, which is fine. However, upon opening it via AutoIT, it returned an error "Insufficient Disk Space". I thought, perhaps that SECINST tried to install to either the hidden Recovery or System partitions instead of to the C Drive. This turned out to be false, as I was able to run it successfully either by clicking on the icon, or running it from CMD.

This is the only program that fails to install from my script, so it may end up not being an AutoIT problem, but I figure I would post about it here. Hoping maybe someone else has had a problem with Windows 7 already. Here is the code, it is fairly simple.

RunWait (@ComSpec & " /c c:\temp\nav\secinst.exe" )
Edited by Tripredacus

Share this post


Link to post
Share on other sites



RunWait (@ComSpec & " /c c:\temp\nav\secinst.exe" )

have you tried specifying a working directory ?

Share this post


Link to post
Share on other sites

Does plain :

RunWait ("c:\temp\nav\secinst.exe" )

Do anything?

Or perhaps ShellExecute()?

Try specifying the working directory.

It may be a UAC permissions thing. Put:

#RequireAdmin

At the top of your script and it will prompt for UAC elevation when the script opens, then anything it runs should have admin privileges too.

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

I created a separate testing script that just runs the program, but it seems to work launching it via ComSpec or just from Windows. However, this app already crashed Explorer when not using my script. I may have jumped the gun, perhaps this program is not compatible and we need a new version for Windows 7. This wouldn't be the first, since we already found our Office install doesn't work either.

I was honestly hoping I could go longer without crashing Windows 7, but I did it -2 days since it came out! :)

Also, note I mentioned I am using 7 in Audit mode. In Audit mode the UAC is not enabled and/or everything is run from the built-in Administrator account.

Update: This is now a non-issue. Intel does not support this program on Windows 7, and will discontinue all support on Vista and XP at the end of the year. So that solves the problem for me, but other users may yet experience this issue launching other programs.

Edited by Tripredacus

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0