Sign in to follow this  
Followers 0
Rad

Problem with transparent window with a GIF being on top

3 posts in this topic

#1 ·  Posted (edited)

Trying to make the image stay on top and be click through, but can't get the image to stay on top. There must be some problem redrawing the image with the $WS_EX_Transparent option but I can't find a way to fix it.

Tried a few different ways to make the image too. Maybe someone who is more advanced can give me a suggestion? I remember seeing an example script that showed a wizard.gif or something and you could draw it outside of the window. Maybe this would be a workaround to the $WS_EX_TRANSPARENT problems. But I don't know.

File uploaded to post #3

Edited by Rad

Share this post


Link to post
Share on other sites



Trying to make the image stay on top and be click through, but can't get the image to stay on top. There must be some problem redrawing the image with the $WS_EX_Transparent option but I can't find a way to fix it.

Tried a few different ways to make the image too. Maybe someone who is more advanced can give me a suggestion? I remember seeing an example script that showed a wizard.gif or something and you could draw it outside of the window. Maybe this would be a workaround to the $WS_EX_TRANSPARENT problems. But I don't know.

Any code you have tried that we can play with?


Serial port communications UDF Includes functions for binary transmission and reception.printing UDF Useful for graphs, forms, labels, reports etc.Add User Call Tips to SciTE for functions in UDFs not included with AutoIt and for your own scripts.Functions with parameters in OnEvent mode and for Hot Keys One function replaces GuiSetOnEvent, GuiCtrlSetOnEvent and HotKeySet.UDF IsConnected2 for notification of status of connected state of many urls or IPs, without slowing the script.

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Oh whoops, lol! I clicked select file then thought the button next to it would upload, but that button says "Clear Selection"

And I just got back too... I'm going to mess around with it some more for awhile

EDIT: Commented out the $WS_EX_TRANSPARENT part inside the GUICreate() function, but still using it in the _WinAPI_SetWindowLong function, and it seems to stay on top. I think it's fixed for now.

imageontop.zip

Edited by Rad

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0