Jump to content
Sign in to follow this  
JimHendricks

Possible problem with WinWaitActive in Win 7

Recommended Posts

JimHendricks

I'm totally new to AutoIT so I may be either repeating something that has already been discussed or more likely being totally stupid. In either case I would rather report this in case it is an actual bug. I was working through the Tutorials and ran into a problem with the "Simple Notepad Automation". Specifically the line WinWaitActive("Notepad", "Do you want to save") was not detecting the dialog as active and therefore not firing the following send. As a diagnostic I removed the "Do you want to save" text and it worked. I verified the text is still the same on that dialog even though I am in Windows 7.

If there is any additional info needed I'll be happy to provide it.

Share this post


Link to post
Share on other sites
EndFunc

I'm totally new to AutoIT so I may be either repeating something that has already been discussed or more likely being totally stupid. In either case I would rather report this in case it is an actual bug. I was working through the Tutorials and ran into a problem with the "Simple Notepad Automation". Specifically the line WinWaitActive("Notepad", "Do you want to save") was not detecting the dialog as active and therefore not firing the following send. As a diagnostic I removed the "Do you want to save" text and it worked. I verified the text is still the same on that dialog even though I am in Windows 7.

If there is any additional info needed I'll be happy to provide it.

I don't think that's just Windows 7. I've had the problem with XP not recognizing the text. Use the AutoIt window info tool to make sure you are getting the correct info. Most of the time I don't need the text.


EndFuncAutoIt is the shiznit. I love it.

Share this post


Link to post
Share on other sites
GEOSoft

See

Opt("WinTitleMatchMode")

and

Opt("WinTextMatchMode")

in the help file

Also note the Title and Text are case sensitive matches


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites
bo8ster

I can't speak for win 7 but u should have no issues with xp, if so post info tool output and code.


Post your code because code says more then your words can. SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y. Use Opt("MustDeclareVars", 1)[topic="84960"]Brett F's Learning To Script with AutoIt V3[/topic][topic="21048"]Valuater's AutoIt 1-2-3, Class... is now in Session[/topic]Contribution: [topic="87994"]Get SVN Rev Number[/topic], [topic="93527"]Control Handle under mouse[/topic], [topic="91966"]A Presentation using AutoIt[/topic], [topic="112756"]Log ConsoleWrite output in Scite[/topic]

Share this post


Link to post
Share on other sites
JimHendricks

Thanks EndFunc, I did use the AutoIt Win Info tool but the text in the dialog actually doesn't display in that tool. I did a copy/paste from the help/tutorial and verified that the copied text is identical to what is actually displayed in the dialog. Based on my troubleshooting, I agree, in this case the text is not really needed, it works without it; It's just a case of this is only the 2nd tutorial and I was already having trouble. I've been in the industry long enough though that 1 minor problem isn't a show stopper, I still like what I see in AutoIt.

Geosoft, when I get the chance I will look up those functions.

Share this post


Link to post
Share on other sites
Confuzzled

Check that the title of the Window actually contains the word "Notepad" - a lot of international versions do not.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.