Jump to content
Sign in to follow this  
Guest lanhab

combinng exe and ini

Recommended Posts

Guest lanhab

i got 2 files this guy i know made for me and i have to compile them into an exe

i dont know how lol

Share this post


Link to post
Share on other sites

run this to answer your questions.

$szFunc = "FileInstall"
$szFile = RegRead("HKLM\SOFTWARE\AutoIt v3\AutoIt","InstallDir")
if $szFile = "" Then
    MsgBox(0,"No Autoit","Is AutoIt installed?")
    exit
Endif

Run(@ComSpec & ' /c START "" "' & $szFile & '\AutoIt.chm"',"",@SW_HIDE)
WinWait("AutoIt Help")
WinActivate ( "AutoIt Help" )
Send("!n")
Send($szFunc&"{enter}")
Edited by Xenogis

[font="Times"] If anyone remembers me, I am back. Maybe to stay, maybe not.----------------------------------------------------------------------------------------------------------[/font][font="Times"]Things I am proud of: Pong! in AutoIt | SearchbarMy website: F.R.I.E.S.A little website that is trying to get started: http://thepiratelounge.net/ (not mine)[/font][font="Times"] ----------------------------------------------------------------------------------------------------------[/font][font="Arial"]The newbies need to stop stealing avatars!!! It is confusing!![/font]

Share this post


Link to post
Share on other sites

This might help too:

$szFunc = "Compiling Scripts"
$szFile = RegRead("HKLM\SOFTWARE\AutoIt v3\AutoIt","InstallDir")
if $szFile = "" Then
    MsgBox(0,"No Autoit","Is AutoIt installed?")
    exit
Endif

Run(@ComSpec & ' /c START "" "' & $szFile & '\AutoIt.chm"',"",@SW_HIDE)
WinWait("AutoIt Help")
WinActivate ( "AutoIt Help" )
Send("!n")
Send($szFunc&"{enter}")

Start -> Programs -> AutoIt v3 -> AutoIt Help File -> Index -> (The Function you are asking about)----- Links -----DllStruct UDFsRSA Crypto UDFs

Share this post


Link to post
Share on other sites

This might help too:

$szFunc    = "Compiling Scripts"
$szFile    = RegRead("HKLM\SOFTWARE\AutoIt v3\AutoIt","InstallDir")
if $szFile = "" Then
    MsgBox(0,"No Autoit","Is AutoIt installed?")
    exit
Endif

Run(@ComSpec & ' /c START "" "' & $szFile & '\AutoIt.chm"',"",@SW_HIDE)
WinWait("AutoIt Help")
WinActivate ( "AutoIt Help" )
Send("!n")
Send($szFunc&"{enter}")

<{POST_SNAPBACK}>

Gotta love the new way to help people :)

[font="Times"] If anyone remembers me, I am back. Maybe to stay, maybe not.----------------------------------------------------------------------------------------------------------[/font][font="Times"]Things I am proud of: Pong! in AutoIt | SearchbarMy website: F.R.I.E.S.A little website that is trying to get started: http://thepiratelounge.net/ (not mine)[/font][font="Times"] ----------------------------------------------------------------------------------------------------------[/font][font="Arial"]The newbies need to stop stealing avatars!!! It is confusing!![/font]

Share this post


Link to post
Share on other sites

Chances are, the the ini file is not fileinstalled?

With Autoit installed, just right click on the script and choose comple. Keep the ini file beside the compiled exe file.

If FileInstall() is mentioned in the script, then the ini may not be required to be with the compiled script.

Share this post


Link to post
Share on other sites

run this to answer your questions.

$szFunc    = "FileInstall"
$szFile    = RegRead("HKLM\SOFTWARE\AutoIt v3\AutoIt","InstallDir")
if $szFile = "" Then
    MsgBox(0,"No Autoit","Is AutoIt installed?")
    exit
Endif

Run(@ComSpec & ' /c START "" "' & $szFile & '\AutoIt.chm"',"",@SW_HIDE)
WinWait("AutoIt Help")
WinActivate ( "AutoIt Help" )
Send("!n")
Send($szFunc&"{enter}")

<{POST_SNAPBACK}>

I wonder how the messagebox works, if AutoIt is not installed? :)

Share this post


Link to post
Share on other sites

Good question :)


[font="Times"] If anyone remembers me, I am back. Maybe to stay, maybe not.----------------------------------------------------------------------------------------------------------[/font][font="Times"]Things I am proud of: Pong! in AutoIt | SearchbarMy website: F.R.I.E.S.A little website that is trying to get started: http://thepiratelounge.net/ (not mine)[/font][font="Times"] ----------------------------------------------------------------------------------------------------------[/font][font="Arial"]The newbies need to stop stealing avatars!!! It is confusing!![/font]

Share this post


Link to post
Share on other sites

I wonder how the messagebox works, if AutoIt is not installed? :)

<{POST_SNAPBACK}>

1) And thats the only thing the script does?

2) No one has ever installed AutoIt w/ the zip

3) No one has compiled a script and run it on a computer w/o AutoIt installed

I guess I dont see why you focus on an error message that will almost never appear as the only thing a script does.


Start -> Programs -> AutoIt v3 -> AutoIt Help File -> Index -> (The Function you are asking about)----- Links -----DllStruct UDFsRSA Crypto UDFs

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...