Sign in to follow this  
Followers 0
unixu

vista autostart

15 posts in this topic

hey i got problem with the vista autostart in my scripts vista and windows7 are somehow canceling my autostart functions how can i fix that because of the vista and w7 admin fuggleshit i have to always use the #requireadmin and then the script wont autostart.

Share this post


Link to post
Share on other sites



hey i got problem with the vista autostart in my scripts vista and windows7 are somehow canceling my autostart functions how can i fix that because of the vista and w7 admin fuggleshit i have to always use the #requireadmin and then the script wont autostart.

Does that mean your profile does not have full Adm priveleges?


Serial port communications UDF Includes functions for binary transmission and reception.printing UDF Useful for graphs, forms, labels, reports etc.Add User Call Tips to SciTE for functions in UDFs not included with AutoIt and for your own scripts.Functions with parameters in OnEvent mode and for Hot Keys One function replaces GuiSetOnEvent, GuiCtrlSetOnEvent and HotKeySet.UDF IsConnected2 for notification of status of connected state of many urls or IPs, without slowing the script.

Share this post


Link to post
Share on other sites

sure it has but the script uses the #requireadmin for computers withour adm privs

all registry entrys are done but vista somehoe blocks them and i cant figure out how...

Share this post


Link to post
Share on other sites

ok letz start all over ^^

my scripts use autoatart with registry entrys this works on winxp but not on vista

my script creates the needed entrys in the registry so the system knows which application want's to autostart

but vista somehowe blocks the application from starting when i boot up the system.

and btw my scripts are not only for me and i can't tell users to disable the user control sys so they can use my scripts ^^

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

ok letz start all over ^^

my scripts use autoatart with registry entrys this works on winxp but not on vista

my script creates the needed entrys in the registry so the system knows which application want's to autostart

but vista somehowe blocks the application from starting when i boot up the system.

and btw my scripts are not only for me and i can't tell users to disable the user control sys so they can use my scripts ^^

oh sry.. well to write to the registry in winvista/win7 u need admin rights so theres the problem

but it shouldnt fail altogether.. it should prompt for admin access?

+ um im not sure i understand what the script does..upon pc startup it writes the keys for win to run programs on loading right? it seems that this should only take effect after a restart..

i think im missing somn

oh i think i get it now... are u sure ure writing to the correct registry keys?

Edited by smartee

Share this post


Link to post
Share on other sites

well thats the thingiii the reg-kexs are written i can see them when i type msconfig and goto the system startup tab

the keys are there but vista still blocks the programm when i start my system the programm is not running but the registry entry is still there

Share this post


Link to post
Share on other sites

well thats the thingiii the reg-kexs are written i can see them when i type msconfig and goto the system startup tab

the keys are there but vista still blocks the programm when i start my system the programm is not running but the registry entry is still there

How do you know they are blocked?

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

because ..

a). the tool has a system tray icon can be seen at the clock

:). i cant find the process when i open the task-manager

Edited by unixu

Share this post


Link to post
Share on other sites

because ..

a). the tool has a system tray icon can be seen at the clock

:). i cant find the process when i open the task-manager

So you mean it isn't started... which is different from being blocked.

Show us the details on how you make the script autostart.


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

I'm assuming these are compiled scripts so please also let us know what folder they are installed to.


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

well i dont know where users save the script

for me on my win7 system itz saved on c:/users/*username*/documents

and the script autostarts via an registry entry in HKLM/software/microsoft/windows/currentversion/run

i see all registry entrys and itz noway of a fault in the script cause it works on winXP and win98 but not on vista oder win7

Share this post


Link to post
Share on other sites

#12 ·  Posted (edited)

well i dont know where users save the script

for me on my win7 system itz saved on c:/users/*username*/documents

and the script autostarts via an registry entry in HKLM/software/microsoft/windows/currentversion/run

i see all registry entrys and itz noway of a fault in the script cause it works on winXP and win98 but not on vista oder win7

If you really want to be helped you will have to start supplying information requested because else its impossible to help you.

So start giving us exact info of your setup/script name/ script location and content of the registry.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

jos i just gave you the needed information

........

the script is saved under c:/users/*username*/documents for my system and of course i spread my script to others on the net i dont know where they save it

the script adds the autostart entry into the registry whats saved in HKLM/software/microsoft/windows/currentversion/run

so i dont know what you need more to know

Share this post


Link to post
Share on other sites

jos i just gave you the needed information

........

the script is saved under c:/users/*username*/documents for my system and of course i spread my script to others on the net i dont know where they save it

the script adds the autostart entry into the registry whats saved in HKLM/software/microsoft/windows/currentversion/run

so i dont know what you need more to know

Not sure what could be unclear about the 2 sentences I wrote...

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

well it seems like you didn't read the thread ....

this is nos script problem itz a win7 problem....

so there is no need to privide any script stuff

and the registry content is what i already posted

C:\Users\Griever\Documents\EsetLogin.exe as a REG_SZ value in HKLM/software/microsoft/windows/currentversion/run

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0