Jump to content
Sign in to follow this  

WiFi auto config gui

Recommended Posts



I have some excellent code from another poster (MattyD I believe) that works well for automatically configuring wireless on XP workstations:

#include "Native_Wifi_Func_V2_2.au3"

$XMLProfile = FileRead("profile.xml")
$hClientHandle = _Wlan_OpenHandle()
$Enum = _Wlan_EnumInterfaces($hClientHandle)
$pGUID = $Enum[0][0]

$a_iCall = DllCall($WLANAPIDLL, "dword", "WlanSetProfile", "hwnd", $hClientHandle, "ptr", $pGUID, "dword", 0, "wstr", $XMLProfile, "ptr", 0, "int", 1, "ptr", 0, "dword*", 0)
ConsoleWrite("Call Error: " & @error & @LF)

I would like to expand on this code, and integrate it into a gui that will allow the user to select from several ssid's (drop down list maybe?) then chose that one and have it automatically configure the wireless settings. I will have several preconfigured xml files, a separate xml profile for each ssid. I would also like to include the xml files into the build if possible, I don't want to have separate files, all just one exe.

Any suggestions would be greatly appreciated.


Share this post

Link to post
Share on other sites

Pretty straight-forward IMO: Your combo need to change the name of the xml profile to be read based of whatever is selected; everything else stays the same.

Put everything (except the #Include of course :)) in a function. The argument needed to be passed to this function is the xml profile.

SNMP_UDF ... for SNMPv1 and v2c so far, GetBulk and a new example script

wannabe "Unbeatable" Tic-Tac-Toe

Paper-Scissor-Rock ... try to beat it anyway :)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.