Sign in to follow this  
Followers 0
JonCross

Problem with BlockInput

8 posts in this topic

I have a script that Updates files on my computers in my lab. During the update I don't want the script to be interrupted so I use Blockinput(1) at the start and before it ends I use BlockInput(0) but I have noticed that every time the script is ran the mouse acts odd. When I click on an Icon on the desktop it opens the properties instead of the program/document. Does anyone have an idea as to what I can do about this?

Share this post


Link to post
Share on other sites



Any ideas as to why BlockInput would affect the computer in this way?

Share this post


Link to post
Share on other sites

I don't know the answer to that question, but I can tell you that you violated forum rules.

Please waiting 24 hours before bumping a post.


For those who are asking questions, look in the help file first. I'm tired of people asking stupid questions about how to do things when 10 seconds in the help file could solve their problem.[quote name='JRowe' date='24 January 2010 - 05:58 PM' timestamp='1264381100' post='766337'][quote name='beerman' date='24 January 2010 - 03:28 PM' timestamp='1264372082' post='766300']They already have a punishment system for abuse.[/quote]... and his his name is Valik.[/quote]www.minikori.com

Share this post


Link to post
Share on other sites

You are experiencing that the ALT key is pressed down, but it is never pressed up. This effectively makes your clicks ALT+Clicks which opens the properties.

Here's a solution: http://www.autoitscript.com/forum/index.php?showtopic=37289&view=findpost&p=512706

Share this post


Link to post
Share on other sites

I don't know the answer to that question, but I can tell you that you violated forum rules.

Please waiting 24 hours before bumping a post.

Sorry, I didn't realize. I will use more patience with my next post.

Share this post


Link to post
Share on other sites

You are experiencing that the ALT key is pressed down, but it is never pressed up. This effectively makes your clicks ALT+Clicks which opens the properties.

Here's a solution: #512706

I will try this out. Thanks ;)

Share this post


Link to post
Share on other sites

Sorry, I didn't realize. I will use more patience with my next post.

It's okay, just trying to make sure you don't get yourself blocked for something you didn't know about.

For those who are asking questions, look in the help file first. I'm tired of people asking stupid questions about how to do things when 10 seconds in the help file could solve their problem.[quote name='JRowe' date='24 January 2010 - 05:58 PM' timestamp='1264381100' post='766337'][quote name='beerman' date='24 January 2010 - 03:28 PM' timestamp='1264372082' post='766300']They already have a punishment system for abuse.[/quote]... and his his name is Valik.[/quote]www.minikori.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0