Sign in to follow this  
Followers 0
Anteaus

Rough text in SciTE

4 posts in this topic

Just wondered if anyone has the answer to this before I go digging-around - in SciTE I find that selecting AutoIt word-highlighting makes the characters very jagged.

Changing font makes no odds. The problem is worst with AutoIt highlighting, and on bold/italic items. It's less severe with other language settings. It goes away if no keyword-highlighting is used.

I use UltraEdit for most of my coding so haven't actually bothered to investigate why until now. UltraEdit is able to use the same or similar wordfile for AutoIt, and yet here it doesn't give rise to the jaggies.

-Any ideas?

Share this post


Link to post
Share on other sites



UltraEdit probably enables font smoothing by default. SciTE, IIRC, respects Window's global setting. Try enabling/disabling ClearType and check if it has any effect.

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Thx for advice. I find that using ClearType instead of standard font-smoothing improves the SciTE display considerably, but it has the side-effect of making text in other windows unsharp, like a defocused camera. Since it can only be set globally I guess I'll have to live without it. From my experience, ClearType suits some display panels, others it does not suit.

The best answer, I guess, might be to do away with bold or italic highlighting as these seem to be the worst-affected.

Edited by Anteaus

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0