Jump to content
Sign in to follow this  
LOULOU

OBJCREATE in v3.1.1.12 (beta) COM25 merge

Recommended Posts

Why don't you post the not-working-code?

<{POST_SNAPBACK}>

Because there is nothing to show when you want to execute the program this programm return this message without explication try to execute a program with that's function and you can reproduce the same behaviour.

Share this post


Link to post
Share on other sites

Because there is nothing to show when you want to execute the program this programm return this message without explication try to execute a program with that's function and you can reproduce the same behaviour.

<{POST_SNAPBACK}>

I have downloaded and installed the beta version 3.1.1.12. No problems with OBJCREATE.

You could check your File extension associations. Does the extension .AU3 still point to AutoIt.EXE with size 147.968 bytes ?

I had a similar problem with SciTE once. When executing a script from within the editor it somehow used a previous AutoIt.exe version. It was an old version that I had moved to a different place.

To solve this problem, I had to edit the entry of AutoIt.EXE in the following registry key:

"HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App Paths"

Regards,

-Sven

Share this post


Link to post
Share on other sites

You are not running by default with the beta version.

Use the Scite update to have both running using the setup.exe or replace install files by the .zip ones

Thanks for testing :)

Share this post


Link to post
Share on other sites

You are not running by default with the beta version.

Use the Scite update to have both running using the setup.exe or replace install files by the .zip ones

Thanks for testing ;)

<{POST_SNAPBACK}>

jpm,

I also noticed: When running your autoit-v3.1.1.12-beta-Setup.exe, it won't replace any files in the AutoIt3 programs directory (even not AutoIt3.exe, nor AutoItSC.bin).

So I was hunting ghosts this afternoon, because I thought I had updated AutoIt.

Is it deliberately done, that your Setup EXE does not replace anything, and that I always have to use the ZIP version to update a previous beta version?

This could cause confusion to some people.

Regards,

-Sven

Share this post


Link to post
Share on other sites

jpm,

I also noticed: When running your autoit-v3.1.1.12-beta-Setup.exe, it won't replace any files in the AutoIt3 programs directory (even not AutoIt3.exe, nor AutoItSC.bin). 

So I was hunting ghosts this afternoon, because I thought I had updated AutoIt.

Is it deliberately done, that your Setup EXE does not replace anything, and that I always have to use the ZIP version to update a previous beta version? 

This could cause confusion to some people.

Regards,

-Sven

<{POST_SNAPBACK}>

I was using the beta exe version for beeing update Autolit and i execute my programm inside SCITE with Execute programm function

Effectively , i modify the registry settings for autolit3 location, and after my programm is running without any problems.

Thanks for the answering

Edited by LOULOU

Share this post


Link to post
Share on other sites

I was using the beta exe version for beeing update Autolit and i execute my programm inside SCITE with Execute programm function

Effectively , i modify the registry settings for autolit3 location, and after my programm is running without any problems.

Thanks for the answering

<{POST_SNAPBACK}>

use the Scite updater or the au3.properties in the upload area to have access to new command alt-F5=run beta alt-F7=compile beta alt-f1=help beta

You don't need to change the registry :)

edit: typo

Edited by jpm

Share this post


Link to post
Share on other sites

jpm,

I also noticed: When running your autoit-v3.1.1.12-beta-Setup.exe, it won't replace any files in the AutoIt3 programs directory (even not AutoIt3.exe, nor AutoItSC.bin). 

So I was hunting ghosts this afternoon, because I thought I had updated AutoIt.

Is it deliberately done, that your Setup EXE does not replace anything, and that I always have to use the ZIP version to update a previous beta version? 

This could cause confusion to some people.

Regards,

-Sven

<{POST_SNAPBACK}>

True I should had a big warning in the installer perhaps some extra links in the menu.

I was focus on non destruction of official version and access with Scite with the alt-... to works on the Beta.

Next upload I try to improve

Thanks :)

Share this post


Link to post
Share on other sites

Come on guys... you must have seen the posts in the 3.1.1++ about the installer change that was proposed.....

I never used the previous Beta installer because i don't want my stable environment possibly messed up with a Beta version!

So thats why the proposal was made to have the Installer install in a subdirectory of the stable version and modify the settings for the SciTE user that they will be able to choose between Production and Beta.

This ofcouse can be done with any editor by added the shortcut ......

Detail here...

JP, we can add some more words to the Warning Box but i doubt if anybody reads that anyways... :D

:)


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...