Sign in to follow this  
Followers 0
kaotkbliss

Something change with pixelsearch/pixelgetcolor?

3 posts in this topic

#1 ·  Posted (edited)

I downloaded the new version of AutoIt, read through the update notes and I don't recall anything changing with those 2 functions specifically (I know there were some pixel functions that had updates but I am pretty sure those specific 2 were untouched)

When I went to run my script, all the splash screens and windows that these pixel searches were looking for were assumed by the script to not be there.

When I added a message box to see the values, if the color was found, the variable was an empty message box, if it was not found it returned a "0".

$point1=PixelSearch(693,241,734,290,0xF7B324)          ;|orange color
    $point2=PixelSearch(445,239,551,280,0x0054E3)          ;|blue
    While $point1<>1                                       ;|waits until orange splash screen is gone
        $point1=PixelSearch(693,241,734,290,0xF7B324)      ;|orange
        $point2=PixelSearch(445,239,551,280,0x0054E3)      ;|blue
        If $point1<>1 Then Sleep(50)                       ;|
        If $point2<>1 Then 
            ControlSend("AutoItlog","",15,"PNet could not be loaded"&" "&@HOUR&":"&@MIN&@CRLF)
            Send("{TAB}{ENTER}")
            norun() 
        EndIf
    WEnd

I had to uninstall the new version and reinstall the old to keep jobs running ;)

*edit*

when I added a message box

MsgBox(0,"",$point1&","&$point2)

it was all blank if it found just 1 color.

Edited by kaotkbliss

010101000110100001101001011100110010000001101001011100110010000

001101101011110010010000001110011011010010110011100100001

My Android cat and mouse game
https://play.google.com/store/apps/details?id=com.KaosVisions.WhiskersNSqueek

We're gonna need another Timmy!

Share this post


Link to post
Share on other sites



Which version of AutoIt was your previous version that worked? On searching the History section of the AutoIt help file, I see that the PixelSearch function was changed in version v3.0.102, August, 2004.

Major Change: Colors now default to the standard RGB format rather than the previous BGR format. This affects PixelSearch() and PixelGetColor().

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Which version of AutoIt was your previous version that worked? On searching the History section of the AutoIt help file, I see that the PixelSearch function was changed in version v3.0.102, August, 2004.

I have been using the version just previous to the one released this month.

I should also note, that I could probably change all my script to read <>0 instead of <>1 as that seems to be the new value, however pixelgetcolor isn't returning the same values it was before as something like If $color=0xFF0000 Then...

is not doing what it is supposed to do when the color matches.

Edited by kaotkbliss

010101000110100001101001011100110010000001101001011100110010000

001101101011110010010000001110011011010010110011100100001

My Android cat and mouse game
https://play.google.com/store/apps/details?id=com.KaosVisions.WhiskersNSqueek

We're gonna need another Timmy!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0