Sign in to follow this  
Followers 0
Matthy

Autoit stops when doing _IEAction("print")

3 posts in this topic

_IENavigate($oIE,"http://site.com)
        _IEAction($oIE,"print")
                Send("{enter}")

But it wont send the enter to findaly print it waits until the window is closed what i dont want

Is there a way to let this work?

cheers

Matthy

Share this post


Link to post
Share on other sites



Not the way you want it to. IE does not return control until after the dialog is closed. You can create another small script that you "Run" just prior to the _IEAction that waits for the dialog, clicks the buttons you want and then exits.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

ok i was thinking of that but thanks for the confirm ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0