Jump to content
Sign in to follow this  
am632

hiding autoinstaller?

Recommended Posts

am632

Hi, I made this script to install AVG 9 Free using the AU3Recorder but i would like to hide the setup windows and just display a message. here is the code...

#NoTrayIcon
Opt("WinWaitDelay",100)
Opt("WinTitleMatchMode",4)
Opt("WinDetectHiddenText",1)
Opt("MouseCoordMode",0)
Run("avg9.exe")
WinWait("AVG Free 9.0 build 716 (12/8/2009)","Welcome to the AVG F")
If Not WinActive("AVG Free 9.0 build 716 (12/8/2009)","Welcome to the AVG F") Then WinActivate("AVG Free 9.0 build 716 (12/8/2009)","Welcome to the AVG F")
WinWaitActive("AVG Free 9.0 build 716 (12/8/2009)","Welcome to the AVG F")
Send("{ALTDOWN}n{ALTUP}")
WinWait("AVG Free 9.0 build 716 (12/8/2009)","I have read the &lic")
If Not WinActive("AVG Free 9.0 build 716 (12/8/2009)","I have read the &lic") Then WinActivate("AVG Free 9.0 build 716 (12/8/2009)","I have read the &lic")
WinWaitActive("AVG Free 9.0 build 716 (12/8/2009)","I have read the &lic")
Send("{ALTDOWN}l{ALTUP}{ALTDOWN}a{ALTUP}")
WinWait("AVG Free 9.0 build 716 (12/8/2009)","&Standard Installati")
If Not WinActive("AVG Free 9.0 build 716 (12/8/2009)","&Standard Installati") Then WinActivate("AVG Free 9.0 build 716 (12/8/2009)","&Standard Installati")
WinWaitActive("AVG Free 9.0 build 716 (12/8/2009)","&Standard Installati")
Send("{ALTDOWN}n{ALTUP}")
WinWait("AVG Free 9.0 build 716 (12/8/2009)","If you are looking f")
If Not WinActive("AVG Free 9.0 build 716 (12/8/2009)","If you are looking f") Then WinActivate("AVG Free 9.0 build 716 (12/8/2009)","If you are looking f")
WinWaitActive("AVG Free 9.0 build 716 (12/8/2009)","If you are looking f")
Send("{ALTDOWN}n{ALTUP}")
WinWait("AVG Free 9.0 build 716 (12/8/2009)","Install the AVG Secu")
If Not WinActive("AVG Free 9.0 build 716 (12/8/2009)","Install the AVG Secu") Then WinActivate("AVG Free 9.0 build 716 (12/8/2009)","Install the AVG Secu")
WinWaitActive("AVG Free 9.0 build 716 (12/8/2009)","Install the AVG Secu")
MouseMove(21,278)
MouseDown("left")
MouseUp("left")
Send("{ALTDOWN}n{ALTUP}")
WinWait("AVG First Run Wizard"," Installation of AVG")
If Not WinActive("AVG First Run Wizard"," Installation of AVG") Then WinActivate("AVG First Run Wizard"," Installation of AVG")
WinWaitActive("AVG First Run Wizard"," Installation of AVG")
MouseMove(494,368)
MouseDown("left")
MouseUp("left")
WinWait("AVG Optimization Scan","Optimize scanning no")
If Not WinActive("AVG Optimization Scan","Optimize scanning no") Then WinActivate("AVG Optimization Scan","Optimize scanning no")
WinWaitActive("AVG Optimization Scan","Optimize scanning no")
MouseMove(241,179)
MouseDown("left")
MouseUp("left")

I think I have to use the @SW_HIDE somewhere but when i put it after the run command, like, 'Run("avg9.exe", SW_HIDE) that did hide the window but the script wouldnt comtinue i think because of the winwaitactive commands. How can I do this??

also I thought I could use the code... SplashTextOn("Setup","Installing AVG 9 Free","400","50","-1","-1",0,"","","")

which did display the message but not sure if this is the way that will be best.

please can anyone help?

thanks

Share this post


Link to post
Share on other sites
DexterMorgan

WinSetState ( "title", "text", flag ) :D

flag would be @sw_hide


code

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.