Jump to content
Sign in to follow this  
randallc

Beta installation separately

Recommended Posts

Hi, Sorry I wasn't sure where to post.

Can someone please point me to clear instructions on installing the main program and the beta in separate directories?

How do I find on the Scite menu (as posted) switching between the two versions?

Thanks, Randall

Share this post


Link to post
Share on other sites

Hi, Sorry I wasn't sure where to post.

Can someone please point me to clear instructions on installing the main program and the beta in separate directories?

How do I find on the Scite menu (as posted) switching between the two versions?

Thanks, Randall

<{POST_SNAPBACK}>

- Download latest BETA installer as advertised in the 3.1.1++ topic

- Download and install Latest Scite4AU3UPD as advertised in the SciTE4Autoit3 topic

:) You are ready to roll !

F1=Help Production

F5=Run Production

F7=CompileProduction

Alt+F1=Help Beta

Alt+F5=Run Beta

Alt+F7=Compile Beta


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

- Download latest BETA installer as advertised in the 3.1.1++ topic

- Download and install Latest Scite4AU3UPD as advertised in the SciTE4Autoit3 topic

Unfortunately, this means that I do not have the original version installed, and "Alt-F5" does nothing, only F5 runs beta16.

Could you tell me, please, timing and diretory for each;

1. v3.1.1 stable/ .....AutoIT directory?

2. Scite Definitions stable/... same?

3. beta16/..... AutoIT ..................or AutoIT /beta? - (done automatically or select?)

4.Scite defsfor beta 16; allow the request to install to AutoIT directory? (is it not over-writing the original definitions in that directory, so stable nt available?

Thanks, Randall

Edited by randallc

Share this post


Link to post
Share on other sites

Hi,

Sorry i still cannot get the helpfile right, even if I give up on having the production running and point everything at the beta directory;

you know I still cannot setup to run both "prod" and "beta"; I don't mind just running the beta, but I would still like those "clear instructions" somewhere; where is the current "properties" file; ?; in which installer were you putting it? which directory should it be in? Why do I have to edit it manually to the beta directory to have the correct help file?

Best, Randall

Share this post


Link to post
Share on other sites

Hi,

Sorry i still cannot get the helpfile right, even if I give up on having the production running and point everything at the beta directory;

you know I still cannot setup to run both "prod" and "beta"; I don't mind just running the beta, but I would still like those "clear instructions" somewhere; where is the current "properties" file; ?; in which installer were you putting it? which directory should it be in? Why do I have to edit it manually to the beta directory to have the correct help file?

Best, Randall

<{POST_SNAPBACK}>

If you use the installer for the beta, in your Start -> Program -> AutoIt v3 -> Beta there are all the entries you use the beta including the help file

Start -> Programs -> AutoIt v3 -> AutoIt Help File -> Index -> (The Function you are asking about)----- Links -----DllStruct UDFsRSA Crypto UDFs

Share this post


Link to post
Share on other sites

Hi,

Sorry i still cannot get the helpfile right, even if I give up on having the production running and point everything at the beta directory;

you know I still cannot setup to run both "prod" and "beta"; I don't mind just running the beta, but I would still like those "clear instructions" somewhere; where is the current "properties" file; ?; in which installer were you putting it? which directory should it be in? Why do I have to edit it manually to the beta directory to have the correct help file?

Best, Randall

<{POST_SNAPBACK}>

Randall,

To reset your whole setup do these steps:

1. install the Autoit 3.1.1 use it uninstall first

2. install the Autoit Beta 3.1.1++

3. install the lastest Scite4au3Upd.exe (4/28/2005 contains all thats needed)

This should give you these options:

F1=Help Production

F5=Run Production

F7=CompileProduction

Alt+F1=Help Beta

Alt+F5=Run Beta

Alt+F7=Compile Beta

If it still always runs Beta then please post the output from F5 and Alt+F5 so i can see what's happening....

Edited by JdeB

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

1. Magic, thanks, alt-f5 working, help files correct version with alt-f1; correct?

2. i think the only thing I did differently was to select the prod defs rather than beta when asked; was this correct?

randall

Share this post


Link to post
Share on other sites

1. help files correct version with alt-f1; correct?

<{POST_SNAPBACK}>

Don't understand the question....

2. i think the only thing I did differently was to select the prod defs rather than beta when asked; was this correct?

<{POST_SNAPBACK}>

The production defs just means that when using SciTE/AU3check/Tidy it will only know the Keywords/Functions of release 3.1.1. If you want to work with the Beta functions you need to run Updatedefs.exe to change between de Beta/Production definitions.

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

QUOTE(deB @ Apr 30 2005, 09:27 PM

Don't understand the question.... )

I mean that ALt-F1 rather than "F1" needed for the help file  new!

The production defs just means that when using SciTE/AU3check/Tidy it will only know the Keywords/Functions of release 3.1.1. If you want to work with the Beta functions you need to run Updatedefs.exe to change between de Beta/Production definitions.

<{POST_SNAPBACK}>

Interesting!

I followed your instructions, and 3.1.1.18 worked from the Alt-F5 if I chose the 3.1.1 install!

I am still confused, but it IS working. I think it would still be worth documenting for others which is thecorrect choice!

Best, Randall

Share this post


Link to post
Share on other sites

I am still confused, but it IS working.  I think it would still be worth documenting for others which is thecorrect choice!

Best, Randall

<{POST_SNAPBACK}>

F1 will be the Last Stable release Helpfile ...3.1.1

Alt-F1 will be the helpfile that comes with the last installed Beta 3.1.1.18

As far as the definition, Scite can only work with One set of definition files, so you need to switch them yourself. Normally when you use the Beta and the last Stable release in mixed mode , you just load the latest Beta definitions since that will contain all functions and keywords......

I am intending to describe this in the helpfile for the next release of the full installer..... But it first needs to be supported by Jon as well, because he's going to build the Beta's again when he has the time again......

Edited by JdeB

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...