Jump to content
Sign in to follow this  
c0re

MemGetStats misreporting total RAM

Recommended Posts

Hi everyone,

I'm using AutoIt version 3.1.1 and my OS is Server 2003 EE. On systems with > 2GB of memory MemGetStats always reports 2097151.99902344. I've verified this on 4GB and 6GB systems. On 1GB and 2GB systems memory is reported correctly, or as close as it gets with regards to the different vendor BIOS'.

I'm new to AutoIt so I could be using MemGetStats incorrectly, but I copied the example out of the help file. this is how i'm using it:

$mem = MemGetStats()

MsgBox(0, "Total physical RAM (KB):", $mem[1]).

I tried a search on the forums for any information regarding my issue and didn't find any relevant hits.

Please tell me if there is a work around for this.

Thank you in advance.

Share this post


Link to post
Share on other sites

Hi everyone,

I'm using AutoIt version 3.1.1 and my OS is Server 2003 EE. On systems with > 2GB of memory MemGetStats always reports 2097151.99902344. I've verified this on 4GB and 6GB systems. On 1GB and 2GB systems memory is reported correctly, or as close as it gets with regards to the different vendor BIOS'.

I'm new to AutoIt so I could be using MemGetStats incorrectly, but I copied the example out of the help file. this is how i'm using it:

$mem = MemGetStats()

MsgBox(0, "Total physical RAM (KB):", $mem[1]).

I tried a search on the forums for any information regarding my issue and didn't find any relevant hits.

Please tell me if there is a work around for this.

Thank you in advance.

<{POST_SNAPBACK}>

You right the Windows API used does not work with memory over 2GB.

as we need to be compatible with windows 9x I will search a compatible fix

Stay tune :(

Share this post


Link to post
Share on other sites

Thanks for the great news!

For future reference, should I always look in the beta section for requested bug fix solutions, or is a response usually sent to the person that requested the fix?

Thanks for making a great tool and complementing it with excellent Help documentation.

Share this post


Link to post
Share on other sites

Thanks for the great news!

For future reference, should I always look in the beta section for requested bug fix solutions, or is a response usually sent to the person that requested the fix?

Thanks for making a great tool and complementing it with excellent Help documentation.

Bug are generally only fix in beta version. We have not provide an official release fix only until now.

As you can see there is no specific forum for beta only so the answer go to the person who writes something.

I hope that's answer your question

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...