Sign in to follow this  
Followers 0
tatty

How to login website

7 posts in this topic

I creat script for login to game website, but I cann't login. The site check for hidden text. I want to know how to send the hidden text to password box.

below is my script;

#include <IE.au3>
#Open Internet Explorer and website audition auto
$oIE = _IECreate ("about:blank")
_IEPropertySet ( $oIE, "Width", "400")
_IEPropertySet ( $oIE, "Height", "600")
_IENavigate ($oIE, "http://sf.gg.in.th/member/logon_v2.aspx?d=d3a5673aa98ae4d3ec8d1e4cf6f01f13") 
sleep (5000)
;$oIE = _IEAttach ("http://sf.gg.in.th/member/logon_v2.aspx?d=d3a5673aa98ae4d3ec8d1e4cf6f01f13", "URL")
sleep (5000)
$oForm1 = _IEFormGetObjByName ($oIE, "form1")
$username = "tattygame2"
$password = "siriratk"
$oQuery = _IEFormElementGetObjByName ($oForm1, "txtLogonX")
_IEFormElementSetValue ($oQuery, $username)
$oQuery1 = _IEFormElementGetObjByName ($oForm1, "txtPasswordX")
_IEFormElementSetValue ($oQuery1, $password)

thak you to everybody in advance.

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

This works just fine...

#include <IE.au3>

$oIE = _IECreate ("http://sf.gg.in.th/member/logon_v2.aspx")
_IEPropertySet ( $oIE, "Width", "400")
_IEPropertySet ( $oIE, "Height", "600")
$oForm1 = _IEFormGetObjByName ($oIE, "form1")
$username = "tattygame2"
$password = "siriratk"
$oUsername = _IEFormElementGetObjByName ($oForm1, "txtLogonX")
_IEFormElementSetValue ($oUsername, $username)

$oPassword = _IEFormElementGetObjByName ($oForm1, "txtPasswordX")
_IEFormElementSetValue ($oPassword, $password)

_IEFormImageClick($oIE, "ImageButton1", "name")
Edited by Steveiwonder

They call me MrRegExpMan

Share this post


Link to post
Share on other sites

I think its ok? its only a website login.


They call me MrRegExpMan

Share this post


Link to post
Share on other sites

This works just fine...

#include <IE.au3>

$oIE = _IECreate ("http://sf.gg.in.th/member/logon_v2.aspx")
_IEPropertySet ( $oIE, "Width", "400")
_IEPropertySet ( $oIE, "Height", "600")
$oForm1 = _IEFormGetObjByName ($oIE, "form1")
$username = "tattygame2"
$password = "siriratk"
$oUsername = _IEFormElementGetObjByName ($oForm1, "txtLogonX")
_IEFormElementSetValue ($oUsername, $username)

$oPassword = _IEFormElementGetObjByName ($oForm1, "txtPasswordX")
_IEFormElementSetValue ($oPassword, $password)

_IEFormImageClick($oIE, "ImageButton1", "name")

Thank you for your kind anyhow it still don't work.

if I login by manual, the password box will see dot (........) then I can login successful.

but if I use this code, the password box isn't hiddened, and the website show invalid password even I use the same password as manual login above. please find image below for clearly identified.

Posted Image

Posted Image

Share this post


Link to post
Share on other sites

I just found what is wrong, now I fix it and program work fine.

Anyhow thank you for all suppport

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0