Sign in to follow this  
Followers 0
SteveKimble

How to find ID of an IE embedded application?

2 posts in this topic

Hi guys,

So basically I need to automate an installation of a third party application.

The window has 5 steps, so up to the 3rd step, there is just a "next" button, for the EULA and default path dir which is pretty easy to find using the Info tool and using the Visible Text, but problems come up on the 4th step:

There is a "next" button, and a check box, but using the Info tool, shows nothing when hovering over the check box, there is no visible text to ID it or hidden text, or handle.

I've tried using mouseclick event to click on the coordinates but that doesn't work either as there is not other text in the 5 steps to ID each step. So I can't make my script wait for the check box.

Using sleep isn't really my perfect solution either, but maybe it's the only way to go.

Thi is what I get when hovering over the check box (I get the same all over the IE form, except for the "next" button)

class Internet Explorer_Server

classnameNN Internet Exlorer_server1

Is there anything I can do to find some ID in a IE form / COM application? Since this is a third party application, I think AutoItX isn't going to do anything for me.

Thanks.

Share this post


Link to post
Share on other sites



Try _IEAttach embedded in the IE Management UDF. You can then use DebugBar (see my sig) and the eyeball icon it places on your browser bar to "Spy other IE Instances" to see the HTML structure and go from there...

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0