Sign in to follow this  
Followers 0
mireazma

SciTe doesn't write correctly from clipboard

12 posts in this topic

1. It says in the Help that you have to use ctrl+c in order to avoid transcripting errors from Window info into the script, as some characters can't be easily (if at all) written by hand.

That's what I did and when I ran my script there was an error somewhere. It took me some time until I figured out it was caused by a mistranscription by SciTe. I even copied/pasted several times and then I saw it: it was a single character that instead of 'ă' it wrote 'a'.

I checked the transcription in notepad and it was correct.

I looked for a possible auto-correct option in options tab in SciTe but I couldn't find one.

What to do?

2. Can I see the intellisense tip again about a function, once I've written after it?

3. Are the brackets interpreted while written into a double quote string? I know that in some languages, in order to get the actual special character, you have to format it with / or something. Is there a table with the special characters that can't be written "as is" into a string?

Thanks in advance.

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

whatever Edited by MvGulik

"Straight_and_Crooked_Thinking" : A "classic guide to ferreting out untruths, half-truths, and other distortions of facts in political and social discussions."
"The Secrets of Quantum Physics" : New and excellent 2 part documentary on Quantum Physics by Jim Al-Khalili. (Dec 2014)

"Believing what you know ain't so" ...

Knock Knock ...
 

Share this post


Link to post
Share on other sites

Thank you for replying to all my questions.

1. I tried your code and as expected it worked just fine. The fact is I've noticed that there's no way at all I could get the 'ă' char inside SciTe; not even by manually typing it, not by find / replace, not in any way. So it's not from the clip. My guess is that there must be an auto-correct option that I must uncheck somewhere.

I was referring to the tutorial Notepad in the AutoIt Help. But it doesn't matter now...

2. It works! with the opening '('

3. I asked that because SciTe colored the opening/enclosing pair of brackets in light blue inside the green quoted string.

So now having all of the other issues solved, I'm stuck with the 'a' char problem and cannot go on with the scripting.

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

whatever Edited by MvGulik

"Straight_and_Crooked_Thinking" : A "classic guide to ferreting out untruths, half-truths, and other distortions of facts in political and social discussions."
"The Secrets of Quantum Physics" : New and excellent 2 part documentary on Quantum Physics by Jim Al-Khalili. (Dec 2014)

"Believing what you know ain't so" ...

Knock Knock ...
 

Share this post


Link to post
Share on other sites

I looked for the 'ă' char in the Character Map and found it is "U+0103:Latin Small Letter A With Breve" I copy it, and when I paste it in SciTE 'a' appears; when I paste it in Notepad, 'ă' appears.

I appreciate you want to help me but it seems I'll have to write from now on in the plain Notepad. Too bad...

Share this post


Link to post
Share on other sites

Use what Jos suggested. Change the encoding to one of the UTF-8 options. Since he is the Scite master (but not the Code Master) then I would suggest that paying attention to what he says will solve a lot of issues.


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

That was it?

I could never have guessed it. Yes, it works now, thank you all.

Excuse my suggestion, but shouldn't it be set as default? or at least put a warn somewhere in plain view for all to see. Man, go figure I considered changing the text editor...

Share this post


Link to post
Share on other sites

That was it?

I could never have guessed it. Yes, it works now, thank you all.

Excuse my suggestion, but shouldn't it be set as default? or at least put a warn somewhere in plain view for all to see. Man, go figure I considered changing the text editor...

I wouldn't want all scriptfiles to be UNICODE by default.

You can set your own defaults by setting the correct parameters in sciteuser.properties.

code.page

output.code.page

character.set

Explanation for these can be found in the helpfile.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Thanks. Man how I hate that dum-bas who made the stupid program with unusual chars. And so to be just perfect, in several buttons he put the & (alt+) just on the funny char in the whole word. He did it on purpose. I just can't move along cause I'm stuck and have to bear with the stupid chars. Man I have a heartache, really. I can't use another program cause it's specifically for my job.

I hardly managed to find sciteuser.properties (a blank page opened). What do I have to write in here? And what about the code.page or the others? Please help me reduce my handicap so I can start scripting from 0 instead of -10 already. Man, it's like reading in a mirror an upside down newspaper...

Share this post


Link to post
Share on other sites

#11 ·  Posted (edited)

whatever Edited by MvGulik

"Straight_and_Crooked_Thinking" : A "classic guide to ferreting out untruths, half-truths, and other distortions of facts in political and social discussions."
"The Secrets of Quantum Physics" : New and excellent 2 part documentary on Quantum Physics by Jim Al-Khalili. (Dec 2014)

"Believing what you know ain't so" ...

Knock Knock ...
 

Share this post


Link to post
Share on other sites

#12 ·  Posted (edited)

Thank you. Whew. Now my file works without modifying the code page every time I start SciTe. All I had to do was to add character.set=238 (East European)in SciTeGlobal.properties and I didn't have to modify code.page (was/is 0). However, the code page in the main menu automatically sets to UCS-2 Little Endian.

Edited by mireazma

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0