Jump to content
Sign in to follow this  
Guest branflakes

ObjCreate in an exe

Recommended Posts

Guest branflakes

I'm running beta 3.1.1.18 and I've been using com to manipulate internet explorer. Today I decided to show a friend what I have done, so I sent and executable to him. I figured they wouldn't need autoit installed if I sent an executable (isnt that the point of an exe?), but this is the error we get:

---------------------------
AutoIt Error
---------------------------
Line 2  (File "C:\Documents and Settings\Me\My Documents\My Received Files\test.au3"):

$oIE=ObjCreate("InternetExplorer.Application.1")
$oIE=^ ERROR

Error: Unknown function name.
---------------------------
OK   
---------------------------

Now, my friend doesnt have autoit installed, so I figured that is the problem. On the other hand, I get the same error when trying to run my exe, even though I have autoit installed.

I'm not sure if I need to include something or if this is a bug... but I thought I'd get it out in the open. Any suggestions?

EDIT: the .au3 file works fine. No errors... it does what it's supposed to... it's just the exe that errors

Edited by branflakes

Share this post


Link to post
Share on other sites
Guest branflakes

compile it with the compiler in the "beta" folder... right-click compile does not use beta engine...

Lar.

<{POST_SNAPBACK}>

Haha, that worked. Thanks.

I thought I had copied over my old compiler to prevent this from happening... I guess I didn't!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...