Sign in to follow this  
Followers 0
styles3000

IE maximize

5 posts in this topic

Is there a function that automatically maximizes the IE window?

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

RunWait("cmd.exe /c " & "start /MIN iexplore.exe http://autoitscript.com/forum/",@ScriptDir,@SW_HIDE)
Sleep(2000)
WinSetState("[CLASS:IEFrame]", "", @SW_MAXIMIZE)

Edited by Sh3llC043r
1 person likes this

[size="5"] [/size]

Share this post


Link to post
Share on other sites

or

WinSetState(_IEPropertyGet($oIE, "hwnd"), "", @SW_MAXIMIZE)

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

You can try this, it works with IE.

$win = WinExists("", "Windows Internet Explorer")
If $win = True Then
    WinSetState("", "Windows Internet Explorer", @SW_MAXIMIZE)
Else
    Sleep(10)
EndIf

elect.

Edited by electrico

Share this post


Link to post
Share on other sites

#5 ·  Posted

On 2/25/2010 at 0:00 PM, Fire said:

 

RunWait("cmd.exe /c " & "start /MIN iexplore.exe http://autoitscript.com/forum/",@ScriptDir,@SW_HIDE)
Sleep(2000)
WinSetState("[CLASS:IEFrame]", "", @SW_MAXIMIZE)

 

OH MY GUDDDD i looked through so many post they all had that hwnd bs and i tried i legit even copied the entire scripts people gave it always failed i add that last line to my code not even copy all your's and it works thank you so much

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0