Jump to content
Sign in to follow this  
stephend

Dircopy fails when using UNC path with netware drive

Recommended Posts

stephend

Hi,

I'm using Windows 7 with a Netware drive. When I run

$var=DirCopy("\\wbsserver\app\nightshift2\clientpackages\miktex", "d:\2010\miktex", 1)

where wbsserver is a netware drive then only the miktex parent folder is copied but none of the files in the folder are, and $var returns 0.#

If instead I run (where L: is the drive mapped to \\wbsserver\app)

$var=DirCopy("L:\nightshift2\clientpackages\miktex", "d:\2010\miktex", 1)
then all the files are copied and $var returns 1.

If I try it with a windows rather than a Netware server then both lines work as they do on XP even with a netware drive. Using Novell Client 2 SP1 for Windows 7 on Windows 7 32bit. There are no issues with perms and the files are not in use. This isn't a big deal as it's such an easy workaround, just thought I should report it. Apologies if this should go into bug reports instead.

Share this post


Link to post
Share on other sites
jchd

UNC behavior can be deceptive. One ought to fear it when Universal (or Uniform) and Convention are used close together! Even the meaning of the acronym is unsure, so...

What you experience doesn't surprise me. What you describe looks rather a Novell level issue than AutoIt.


This wonderful site allows debugging and testing regular expressions (many flavors available). An absolute must have in your bookmarks.
Another excellent RegExp tutorial. Don't forget downloading your copy of up-to-date pcretest.exe and pcregrep.exe here
RegExp tutorial: enough to get started
PCRE v8.33 regexp documentation latest available release and currently implemented in AutoIt beta.

SQLitespeed is another feature-rich premier SQLite manager (includes import/export). Well worth a try.
SQLite Expert (freeware Personal Edition or payware Pro version) is a very useful SQLite database manager.
An excellent eBook covering almost every aspect of SQLite3: a must-read for anyone doing serious work.
SQL tutorial (covers "generic" SQL, but most of it applies to SQLite as well)
A work-in-progress SQLite3 tutorial. Don't miss other LxyzTHW pages!
SQLite official website with full documentation (may be newer than the SQLite library that comes standard with AutoIt)

Share this post


Link to post
Share on other sites
GEOSoft

I know this is a very old thread. I just want to put a comment here for future reference.

I had the same problem as the OP; DirCopy() wouldn't work to the UNC path but it did to a Mapped drive.

The solution was to add the share name into the path.

\\UNCPath\sharename\folder


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×