Jump to content
Sign in to follow this  

[solved] ftpex : ftplisttoarray - force reload

Recommended Posts


Hi all, and thanks in advance

I'm using 7zip.au3 and ftpex.au3 to write an automated off-site backup script - its more complicated than I first imagined,

my latest problem is how to get ftplisttoarray to read from the ftpserver rather than the cache.

I realise you can use a reload flag with the function like thus:


but it doesnt seem to effect the function's behaviour, I've deleted a bunch of files from the server (using filezilla) but my script still lists them with ftplisttoarray.

The autoit documentation is a little sketchy on ftpex.au3 - but the MSDN library gives a full run-down of the available flags.

I also tried the other flag INTERNET_FLAG_RESYNCHRONIZE (the documentation on each is a bit ambiguous to a n00b) but to no avail - no change in behaviour.

so im a little stumped - anyone have any thoughts?

Edited by Mr5o1

Share this post

Link to post
Share on other sites

heheh.. how embarassing - realised my script was accessing a different folder on the ftp server - so i hadnt actually deleted the files that ftplisttoarray was returning.

all sorted

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.