Jump to content
Sign in to follow this  
joboy2k

unterminated string

Recommended Posts

joboy2k

hey im having a problem with run my script..

it keeps coming up with "Unterminated String"

and keeps telling me its line 6

so i checked line 6 and all that it contains is "#Include <Misc.au3>"

so i moved it down a line just to see if it would follow it to line 7, i tried to run it again and aparently line 6 has unterminated string, even though it is blank.

obviously i dont understand what unterminated string is cause i cant see why even a blank space would bring up errors.

is there anyone that can tell me what the error "Unterminated string" normally is caused by?

thanks in advance

Share this post


Link to post
Share on other sites
Jos

hey im having a problem with run my script..

it keeps coming up with "Unterminated String"

and keeps telling me its line 6

so i checked line 6 and all that it contains is "#Include <Misc.au3>"

so i moved it down a line just to see if it would follow it to line 7, i tried to run it again and aparently line 6 has unterminated string, even though it is blank.

obviously i dont understand what unterminated string is cause i cant see why even a blank space would bring up errors.

is there anyone that can tell me what the error "Unterminated string" normally is caused by?

thanks in advance

You have forgotten to terminate a literal string ... missing a double or single quoute somewhere.

Show the code snippet for more accurate help

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
joboy2k

dont worry i found the reason.

on line 10 there was this command

#include "C:\Users\me\Desktop\logo.ico"

i deleted this and error was gone.

does anyone know the reason why this was a problem?

and why did it keep saying the error was line 6?

Edited by joboy2k

Share this post


Link to post
Share on other sites
Jos

dont worry i found the reason.

on line 10 there was this command

#include "C:\Users\me\Desktop\logo.ico"

i deleted this and error was gone.

does anyone know there reason why this was a problem?

and why did it keep saying the error was line 6?

Well that is pretty easy: FileInclude is to include files that contain AutoIt3 code NOT Binary files. For that you would need to use FileInstall().

The Line 6 was probably referring to the Include file, not your source script?

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
joboy2k

k k my bad.

must be having a bad morning xD

thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.