Sign in to follow this  
Followers 0
stoneheart

problem with setup app's

4 posts in this topic

I working to automated some application and I have problem with it,

I use the command winWait,if not,then,winActive,winWaitActive and Send

But sometimes the script stooped and the window is active but don’t send what I told it to send like Enter or ALT+N....

And if I send it manually some time it’s continue the script

For example

WinWait("SETUP Application - InstallShield Wizard","WARNING: This progra")

If Not WinActive("SETUP Application - InstallShield Wizard","WARNING: This progra") Then WinActivate("SETUP Application - InstallShield Wizard","WARNING: This progra")

WinWaitActive("SETUP Application - InstallShield Wizard","WARNING: This progra")

Send("{!}n")

Not: am new in the AutoIt and am just use it to automated installations

Share this post


Link to post
Share on other sites



any Help :(

Share this post


Link to post
Share on other sites

stoneheart,

Please do not bump your own threads within 24 hrs. :(

Remember this is not a 24/7 support forum - those who answer are only here because they like helping others and have some time to spare. You just have to wait until someone who knows something about your particular problem, and is willing to help, comes online. Be patient and someone will answer eventually.

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

...

But sometimes the script stooped and the window is active but don’t send what I told it to send like Enter or ALT+N....

...

Send("{!}n")

Have a good read through the help file on the topic of Send. The remarks section can be very informative.

Here is the start of the remarks of Send that seems relevant to your issue.

Remarks

See the Appendix for some tips on using Send. AutoIt can send all ASCII and Extended ASCII characters (0-255), to send UNICODE characters you must use the "ASC" option and the code of the character you wish to send (see {ASC} at the bottom of the table below).

The "Send" command syntax is similar to that of ScriptIt and the Visual Basic "SendKeys" command. Characters are sent as written with the exception of the following characters:

'!'

This tells AutoIt to send an ALT keystroke, therefore Send("This is text!a") would send the keys "This is text" and then press "ALT+a".

...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0