Sign in to follow this  
Followers 0
Valik

Textpad Syntax Installer Needs Tweaked

1 post in this topic

The option to set TextPad as the default editor caused problems for me. It at the very least needs a quotes around the %1. Below is a registry dump of my settings settings I use on XP Pro (It's a slightly modified version of what TextPad uses when you use it to associate a file).

I use both DDE and the command line, it seems to present less issues. TextPad normaly sets up the DDE stuff and just uses '"C:\Program Files\TextPad4\TextPad.exe" - s', but by adding the "%1", it eliminates a problem where trying to edit a shortcut to a script would load nothing. DDE prevents multiple copies of the editor from opening simultaneously when you select multiple files. (This may be causing TextPad to attempt to open the file twice, once on the command line, then again through DDE (or vice versa), but since you can only have on instance of a file open at a time, this isn't a problem).

Here's the registry dump of the Edit key.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\AutoIt3Script\Shell\Edit]
@="Edit Script"

[HKEY_CLASSES_ROOT\AutoIt3Script\Shell\Edit\command]
@="\"C:\\Program Files\\TextPad 4\\TextPad.exe\" -s \"%1\""

[HKEY_CLASSES_ROOT\AutoIt3Script\Shell\Edit\ddeexec]
@="[open(\"%1\")]"

[HKEY_CLASSES_ROOT\AutoIt3Script\Shell\Edit\ddeexec\Application]
@="TextPad"

[HKEY_CLASSES_ROOT\AutoIt3Script\Shell\Edit\ddeexec\Topic]
@="System"

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0