Sign in to follow this  
Followers 0
BillLuvsU

Checking up on RunAs()

8 posts in this topic

Does anybody know how you would check if the password and username worked in the RunsAs() command? I am trying to make an installer that would work for everybody for my game. It will have a gui with 2 inputs for the username and pass. if they are incorrect it will do this again, if they are they will continue with the installer. I would really appreciate if someone would atleast provide me with a theory on how to do it.


[center][/center]Working on the next big thing.Currently Playing: Halo 4, League of LegendsXBL GT: iRememberYhslaw

Share this post


Link to post
Share on other sites



Does anybody know how you would check if the password and username worked in the RunsAs() command? I am trying to make an installer that would work for everybody for my game. It will have a gui with 2 inputs for the username and pass. if they are incorrect it will do this again, if they are they will continue with the installer. I would really appreciate if someone would atleast provide me with a theory on how to do it.

<{POST_SNAPBACK}>

RunAsSet($Username, @ComputerName, $Password)
RunWait(@ComSpec & " /k exit", "", @SW_HIDE)
If @error = 1 Then
    MsgBox(48, "Error", "Error ..........")
EndIf

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

lol, thankyou. I guess I was just having a newbie moment lol.


[center][/center]Working on the next big thing.Currently Playing: Halo 4, League of LegendsXBL GT: iRememberYhslaw

Share this post


Link to post
Share on other sites

Ok, I ran the program but it crashes autoit. I get an error message saying:

Error: Unable to execute the external program.

Logon Failure: unknown user name or bad password.


[center][/center]Working on the next big thing.Currently Playing: Halo 4, League of LegendsXBL GT: iRememberYhslaw

Share this post


Link to post
Share on other sites

Ok, I ran the program but it crashes autoit. I get an error message saying:

Error: Unable to execute the external program.

Logon Failure: unknown user name or bad password.

<{POST_SNAPBACK}>

Do you have AutoItSetOption("RunErrorsFatal", 0) at the start of your script ?

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

No


[center][/center]Working on the next big thing.Currently Playing: Halo 4, League of LegendsXBL GT: iRememberYhslaw

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0