Sign in to follow this  
Followers 0
Wooltown

Problems running a Java program from AutoIT

1 post in this topic

I have a problem running a Java program using RUN inside AutoIT

I run it like this:

$GhPID = Run('"java.exe" -Xmx256 -classpath "' & @UserProfileDir & '\EPA" EPAStarter -configfile="\\eseldna003\bmtpspc0\EPA_Config\Config\Basic\ecs_r7l.mesp" -ezflash -buildRoot "C:\flashME" -target all', '', @SW_HIDE, $STDERR_CHILD + $STDOUT_CHILD)

The Java program is updated and now when I exit from AutoIT, AutoIT crashes, see the attached files.

Is there any way to run the Java process isolated from AutoIT ? It seems like it is corrupting the Address space for AutoIT.

In the previous version of the Java program it worked as it should.

Any help apreciated.

post-6286-1273049748605_thumb.jpg

post-6286-12730497546816_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0