Jump to content
Sign in to follow this  
MadCoder

Newbie handle question

Recommended Posts

MadCoder

In a prior post (which I answered myself) I found where my bug lied., When trying to close Visual Studio after a compile, it seems that our third party debugger

makes Visual Studio loses focus so sending exit keys never work because that form is no longer in focus.

I've search the Autoithelp file and can find anything specific to what I need, but I'm sure it's there. Basically before I send the close keys I need to make sure Visual Studio has focus. Any help?

Share this post


Link to post
Share on other sites
PsaltyDS

You should generally use ControlSend() vice Send(). That should work without the target window having focus.

:idea:


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites
MadCoder

Thanks for the reply. I will look up that function and see how it goes...

Thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.