Jump to content
Sign in to follow this  
UEZ

Disable TCP/IPv6

Recommended Posts

UEZ

I want to uncheck 'Internet Protocol Version 6 (TCP/IPv6)' from connection properties but I couldn't find a way to do it on Vista+ machines!

Setting 'DisabledComponents' to '0xffffffff' in 'HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters' didn't help!

Although I couln't find any IPv6 binding (ipconfig /all) after reboot - 'Internet Protocol Version 6 (TCP/IPv6)' is still checked in Local Area Connection Properties!

Any help?

BR,

UEZ

Edited by UEZ

Please don't send me any personal message and ask for support! I will not reply!

Selection of finest graphical examples at Codepen.io

The own fart smells best!
Her 'sikim hıyar' diyene bir avuç tuz alıp koşma!
¯\_(ツ)_/¯  ٩(●̮̮̃•̃)۶ ٩(-̮̮̃-̃)۶ૐ

Share this post


Link to post
Share on other sites
Richard Robertson

Why do you need to disable it? If the network doesn't support it, then it just won't do anything. I've got IPv6 services running on at least one machine on my network but the network itself is still v4 and it works fine.

Share this post


Link to post
Share on other sites
UEZ

Why do you need to disable it? ...

Because of some silly documentation where 'Internet Protocol Version 6 (TCP/IPv6)' is unchecked. Target is to script all the tasks which are normally made manually by humans, e.g. changing time zone on Windows Server 2008... :idea:

BR,

UEZ


Please don't send me any personal message and ask for support! I will not reply!

Selection of finest graphical examples at Codepen.io

The own fart smells best!
Her 'sikim hıyar' diyene bir avuç tuz alıp koşma!
¯\_(ツ)_/¯  ٩(●̮̮̃•̃)۶ ٩(-̮̮̃-̃)۶ૐ

Share this post


Link to post
Share on other sites
Richard Robertson

I looked online and I saw that one page said to set DisabledComponents to 0xFF, not 0xFFFFFFFF. You could try that to start.

I couldn't find anything other than that.

Share this post


Link to post
Share on other sites
UEZ

I looked online and I saw that one page said to set DisabledComponents to 0xFF, not 0xFFFFFFFF. You could try that to start.

I couldn't find anything other than that.

That's the reason why opened this thread. :idea: I thought that somebody was in the same situation to find a solution for this particular problem and I didn't want to reinvent the wheel.

Btw, 0xFF makes no difference!

Thanks anyway for your efforts.

BR,

UEZ


Please don't send me any personal message and ask for support! I will not reply!

Selection of finest graphical examples at Codepen.io

The own fart smells best!
Her 'sikim hıyar' diyene bir avuç tuz alıp koşma!
¯\_(ツ)_/¯  ٩(●̮̮̃•̃)۶ ٩(-̮̮̃-̃)۶ૐ

Share this post


Link to post
Share on other sites
evilertoaster

The DisabledComponents disables IPV6 for you're computer as a whole.

The checkbox in the properties indicates which protocols that adapter supports (even if those protocols aren't enabled).

So to disable it on an adapter by adapter basis is a bit more work, here's a guide which words it in another way as well as show how to do the adapter by adapter method- http://srvcore.wordpress.com/2010/01/06/how-to-disable-ipv6-in-windows-2008-full-and-core-editions/

Share this post


Link to post
Share on other sites
UEZ

The DisabledComponents disables IPV6 for you're computer as a whole.

The checkbox in the properties indicates which protocols that adapter supports (even if those protocols aren't enabled).

So to disable it on an adapter by adapter basis is a bit more work, here's a guide which words it in another way as well as show how to do the adapter by adapter method- http://srvcore.wordpress.com/2010/01/06/...-in-windows-2008-full-and-core-editions/

Thanks for the link but 1st part was not new to me. 2nd part is for Windows Core versions but I tried that way, too but that made no difference to 1st method. No TCP/IPv6 bindings but TCP/IPv6 is still selected in NIC properties.

BR,

UEZ


Please don't send me any personal message and ask for support! I will not reply!

Selection of finest graphical examples at Codepen.io

The own fart smells best!
Her 'sikim hıyar' diyene bir avuç tuz alıp koşma!
¯\_(ツ)_/¯  ٩(●̮̮̃•̃)۶ ٩(-̮̮̃-̃)۶ૐ

Share this post


Link to post
Share on other sites
evilertoaster

I'm pretty sure it does work (as Ive used it in the past). To clarify, you will be removing the adapter GUID from HKLM\System\CurrentControlSet\services\TCPIP6\Linkage\Bind (\Route) (\Export) as well as removing the TCPIPV6 from the upper bind at HKLM\System\CurrentControlSet\Control\CLASS\{4D36E972-E325-11CE-BFC1-08002BE10318}\{**YourInstanceHere)**\Linkage\UpperBind.

This does disable IPV6 form the adapter, this I have verified. Keep in mind though that the checkbox you see in the connection properties is managed by a different key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\Config

The format is unknown to me, so I'm not sure how to modify it correctly. It is however, automatically re-generated if you delete it and reboot or invoke QueryIterface as mentioned in this thread: http://www.keyongtech.com/2480020-generating-config-key-in-hklm

Share this post


Link to post
Share on other sites
UEZ

I'm pretty sure it does work (as Ive used it in the past). To clarify, you will be removing the adapter GUID from HKLM\System\CurrentControlSet\services\TCPIP6\Linkage\Bind (\Route) (\Export) as well as removing the TCPIPV6 from the upper bind at HKLM\System\CurrentControlSet\Control\CLASS\{4D36E972-E325-11CE-BFC1-08002BE10318}\{**YourInstanceHere)**\Linkage\UpperBind.

Yes it is working as mention above.

This does disable IPV6 form the adapter, this I have verified. Keep in mind though that the checkbox you see in the connection properties is managed by a different key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\Config;;The

formatis unknownoto me me, so Inotnsureuhowhto modifyiit correctlytlIt is howeverveautomaticallylly re-generated if you delete it and reboot or invoke QueryIterface as mentioned in this thread: http://www.keyongtech.com/2480020-generating-config-key-in-hklm

Thanks, that helped me to find out where the key is! When I compare it with selected and unselected TCP/IPv6 (export the key) then the only difference is to the end (last 17 lines) but there are a lot of difference which I don't know how they are set!

BR,

UEZ


Please don't send me any personal message and ask for support! I will not reply!

Selection of finest graphical examples at Codepen.io

The own fart smells best!
Her 'sikim hıyar' diyene bir avuç tuz alıp koşma!
¯\_(ツ)_/¯  ٩(●̮̮̃•̃)۶ ٩(-̮̮̃-̃)۶ૐ

Share this post


Link to post
Share on other sites
changenosh

I'm pretty sure it does work (as Ive used it in the past). To clarify, you will be removing the adapter GUID from HKLMSystemCurrentControlSetservicesTCPIP6LinkageBind (Route) (Export) as well as removing the TCPIPV6 from the upper bind at HKLMSystemCurrentControlSetControlCLASS{4D36E972-E325-11CE-BFC1-08002BE10318}{**YourInstanceHere)**LinkageUpperBind.

This does disable IPV6 form the adapter, this I have verified. Keep in mind though that the checkbox you see in the connection properties is managed by a different key: HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlNetworkConfig

The format is unknown to me, so I'm not sure how to modify it correctly. It is however, automatically re-generated if you delete it and reboot or invoke QueryIterface as mentioned in this thread: http://www.keyongtech.com/2480020-generating-config-key-in-hklm

If I remove tcpipv6 as above instructions, the connection property is always checked. Could someone help me for this topic? And what is QueryInterface? Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×