Sign in to follow this  
Followers 0
ttabol

Need to launch VBS with AutoIt

3 posts in this topic

Howdy All!

I need to launch a vbs with AutoIt, tried run and got an error. Can anyone provide the code to do this?

Thanks!

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Howdy All!

I need to launch a vbs with AutoIt, tried run and got an error. Can anyone provide the code to do this?

Thanks!

<{POST_SNAPBACK}>

Run("cscript.exe c:\test.vbs")
or, if you want the GUI pieces...
Run("wscript.exe c:\test.vbs")
Edited by DaleHohm

Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Thanks! That works perfect.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0