Sign in to follow this  
Followers 0
CreeTar

$GUI_DROPACCEPTED and Opt("GUIOnEventMode", 1)

3 posts in this topic

Hi,

short problem, while dragging my edit field does not recognize that something was dragged onto it.

Opt("GUIOnEventMode", 1)

GUICreate("test", -1, -1, 300, 300, $GUI_SS_DEFAULT_GUI, $WS_EX_ACCEPTFILES) ;so gui accept files
GUISetOnEvent($GUI_EVENT_DROPPED, "dropdropdrop") ;no matter where i drag and drop, dropdropdrop is never called

GUICtrlCreateInput("", 10, 10, 290, 290, $ES_MULTILINE) ;my edit
GUICtrlSetState($GUI_DROPACCEPTED, -1) ;does also accept a drop

I had before a version using no EventMode, but I found it cleaner for programming.

Any tips? I searched the board but haven't found something, only non-eventmode examples.

Regards

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Looks like that code is good, show us your dropdropdrop function please...No wait, GUICtrlSetState has wrong parameters. It should be GUICtrlSetState(-1, $GUI_DROPACCEPTED)

Edited by jaberwocky6669

Share this post


Link to post
Share on other sites

Looks like that code is good, show us your dropdropdrop function please...No wait, GUICtrlSetState has wrong parameters. It should be GUICtrlSetState(-1, $GUI_DROPACCEPTED)

Wow, that is quite annoying ^^ i did it right in the one script and now messed it up :P

precious 20min. of my life :party: thanks a lot for spotting it :mellow:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0