Sign in to follow this  
Followers 0
photonbuddy

MouseMove() and Windows VirtualPC

6 posts in this topic

Hi All,

I've been working with Windows VirtualPC on my Windows7/x64 Ultimate PC. I have a couple of programs that don't play nice on Win7.

For the most part, I have sorted the problems, but this evening, after putting the finishing touches on my virtualPC environment, I discovered that the MouseMove() function no longer works.

This probably has something to do with the way VirtualPC hooks into the rest of the system, but thought I ask if anyone has a workaround for this problem?

Any help is much appreciated.

Share this post


Link to post
Share on other sites

You need the script to run ON the vitural PC, not run from the real PC.

I have compiled the script as an x86 executable without UPX and copied the executable onto the virtualPC's HDD, and run it from within the VirtualPC. Still no joy :mellow:

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Are you trying to interact with the script VIA the master PC at all? Such as a TCP/IP thing?

Compile this script to see what happens:

sleep(2000) 
$pos = MouseGetPos() 
MsgBox(0, "Mouse x,y:", $pos[0] & "," & $pos[1])

Do you get a report on where the mouse is and does it change each time you run it from the virtual PC?

Edited by Volly

Share this post


Link to post
Share on other sites

Are you trying to interact with the script VIA the master PC at all? Such as a TCP/IP thing?

No. It's all in the virtual pc. I have the virtualPC running in full screen mode, as this is the way to use the windows keys etc.

Do you get a report on where the mouse is and does it change each time you run it from the virtual PC?

I ran AU3Info, and it is reporting the correct mouse position. I then re-ran the little test program I wrote (3 MouseMove()'s with a pause between each) and what I saw was intriguing.

As each MouseMove() is executed, AU3Info shows the mouse position changing, but the pointer remained where it was.

Share this post


Link to post
Share on other sites

Hi photonbuddy,

in the virtual pc window press Right-Alt key + i

Choose to install virtual PC additions

Restart Virtual PC

In the Virtual PC console window choose Actions -> Settings, then "Mouse".

Uncheck "Use pointer integration".

/jezze

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0