Jump to content
Sign in to follow this  
nacitar

Bug with holding RAlt/RCtrl/RShift?

Recommended Posts

nacitar

Send("{RALT Down}")

Sleep(1000)

Send("{RALT Up}")

End result? Left alt is considered down, as well as right alt. Start -> run -> osk to open the on screen keyboard and see what this does.

There's no RALTDOWN either like there is "altdown"... so is there no way to hold down these right alt/ctrl/shift keys and release when I wish? Also, prefixes are provided to do (ignoring right variants) ctrl+alt+key and such, but I didn't see any prefixes for the right variants. Are there any?

Share this post


Link to post
Share on other sites
nacitar

Note that I've only observed this misbehavior on windows 7 x64, and haven't tested elsewhere.

Also note that I can easily achieve what I'm trying to achieve using AutoHotkey. I'm actually in the process of converting a large autohotkey script to autoit because autoit's script language is much more elegant and I'm tired of working around several of autohotkey's bugs/limitations. I'm very much hoping that a simple thing like this doesn't prevent me from making the switch.

And though this may seem insignificant, the program I'm interfacing with lets me set hotkeys with the right modifier keys as part of them (so, ralt+rctl+numpad0 for example), and by setting them to these obscure combinations I can ensure that I never press them myself but only through the script, allowing me to use these obscure hotkeys in functions to make the program do various things. Without this ability autoit becomes useless in my use case as it's impossible to achieve my goal.

Edited by nacitar

Share this post


Link to post
Share on other sites
nacitar

Anyone else even confirm that it's broken for them? Expected more of a response of a bug that disallows a _macro program_ to hold down a key every keyboard has...

Share this post


Link to post
Share on other sites
Tvern

The Ralt Up seems to end up setting Ctrl down and LAlt down for me.

Win7 Ultimate x6

Edit: Did you check for any references in the bug tracker?

Edited by Tvern

Share this post


Link to post
Share on other sites
nacitar

The Ralt Up seems to end up setting Ctrl down and LAlt down for me.

Win7 Ultimate x6

Edit: Did you check for any references in the bug tracker?

Pretty much exactly what I'm seeing. And no, I haven't checked the bug tracker yet... but I shall. I posted here first in case I was doing something that others would find obviously wrong, though I was pretty sure it was not.

EDIT: searching for ralt and "right alt" and a few others didn't uncover anything. take note this bug effects other keys too, like rctrl and rshift.

Edited by nacitar

Share this post


Link to post
Share on other sites
nacitar

Is there no resolution for this? o.O

Share this post


Link to post
Share on other sites
OctopusCO

Just curious if you've tried using "SendKeyDownDelay" instead of the three consecutive commands? Seems like that would work for you as well and may not cause the anomaly.

Share this post


Link to post
Share on other sites
EnderWiggin

Send("{RALT Down}")

Sleep(1000)

Send("{RALT Up}")

End result? Left alt is considered down, as well as right alt. Start -> run -> osk to open the on screen keyboard and see what this does.

There's no RALTDOWN either like there is "altdown"... so is there no way to hold down these right alt/ctrl/shift keys and release when I wish? Also, prefixes are provided to do (ignoring right variants) ctrl+alt+key and such, but I didn't see any prefixes for the right variants. Are there any?

Your problem interests me as well. I am also on windows 7 X64 and I'm just learning to script. I read about autohotkey and autoit, and this seemed like the clear choice to me. But immediately have been stymied trying to get !n to work as alt-n: maybe there's some kind of problem getting autoit to work with alt-keys on windows7 X64?

Share this post


Link to post
Share on other sites
nullspace

Your problem interests me as well. I am also on windows 7 X64 and I'm just learning to script. I read about autohotkey and autoit, and this seemed like the clear choice to me. But immediately have been stymied trying to get !n to work as alt-n: maybe there's some kind of problem getting autoit to work with alt-keys on windows7 X64?

I have been struggling with this problem for some time as well. I've tried to use other variants (e.g. rctrl up, ralt up, ralt down, etc.) to try to "bug" the left ctrl button into coming back up, but with no success. Anyone found a workaround for this yet?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×